Advanced Privacy takes down the Internet connection

Hello, I am playing around with Advanced Privacy from few days, however it causes dramatic slow down in the Internet speed, like from aroud 55 Mbps without Adv. Privacy to around 5 Mbps with it. When I get on the mobile data LTE (I have market “Global” in settings) sometimes I even loose the Internet connection altogether. I have already check two main phone carriers in my area for this question, both of them, for few times a day loose Internet connection altogether when I use mobile data LTE together with Advanced Privacy.

The question is, how can I set up Advanced Privacy to be able to use it and to not loose the Internet connection?

Or how to set up the phone, so the Advanced Privacy do not shut down my NetGuard VPN stable connection with which I can reach the Internet :thinking:

Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone

1 Like

Sounds like a side effect of Hide My IP. Using the Tor network would have that effect.

Hide my IP is also responsible for connection loss, this is a known problem.

A workaround: be sure to disable Advanced Privacy by turning the global toggle off, then reactivate it with Hide my IP set to a random country, then go to Settings-Network-VPN and set AP VPN it as Always on. Connection loss still happen but are very rare now.

2 Likes

this sounds nice, thank you :heart:

however I have already managed to forget this vpn :worried: so NetGuard could stop sending me constant notifications :woman_facepalming: is there any way I could add the Advanced Privacy VPN without the OS factory reset?

hmmm … but is Advanced Privacy VPN?

Quoting …

Side effects

The implementation of Orbot bridges all the devices’s Internet traffic through the Tor network. This was initially designed for VPN Services. That’s why Hide My IP appears as a VPN in /e/OS. We are working on another solution to route the devices’s traffic directly through Tor, to avoid this confusion.

2 Likes

1 Like

unfortunately I clicked “forget vpn” :cry:

Maybe clearing the cache and stored data from AP (in Settings-Apps-three dots menu-Show system apps) could help?

2 Likes

ok, I tried in the following order:

  1. cleared cache in the Advanced Privacy as in the system app, no result
  2. I formatted the OS to the basic step as when you start the OS, no result
  3. I entered recovery, Format Data, no result
  4. I have installed TWRP and cleared and wiped everything except from USB-OTG, then I installed /e/OS from scratch and still nothing changed in Advanced Privacy :thinking:

and know I wonder what is better, to treat both sets, a and b with TWRP or install e.g. Lineage OS and than wipe it and install /e/OS again :thinking:

ok, it seems that I must have broken something more :frowning: I have installed Lineage OS 18 (android 11) on my Moto G7 Power, after that i used TWRP once again and now I installed back /e/OS, and still have empty space in the Settings-Network-VPN :frowning:
could someone drop here the screenshot from under the toggle on the right sight of the Advanced Privacy in the VPN section? maybe I could add it by hand, but unfortunately I have no idea what should I fill in there

1 Like

Here is a screenshot in the VPN section but you won’t get any information from it I guess.

Did you check that AP gets the proper authorizations to access VPN?

1 Like

okay, finally the solution seemed to be simple enough to use window with app permission, cache and so on (system app) that I blocked it and then I clicked open to reactivate, and only this helped to get Advanced Privacy back :hushed:
thank you everyone so much for the brainstorm with this issue :grin:

2 Likes