Advanced Privacy tool on GSI


I’ve been using GSI images of e/os/ on unsupported devices for a few months now. I really like the option of installing e/os/ on virtually any device that supports Project Treble and I never had any problems with it.

However, I really, really miss the Advanced Privacy tool. GSI images are 0.23 version of e/os/ and I believe AP tool was introduced in later iterations.

So I found this tutorial on gitlab that describes how to install Advanced Privacy:

It’s very well written and I easily followed all the steps but got stuck on the last one:
5. Allow the fake location service to run in background. Add in the file /system/etc/permissions/platform.xml .

I can find platform.xml file but what should I add in it? Same permission code from step 4 or advancedprivacy app (foundation.e.advancedprivacy.apk) as fake location service?

Even without completing the last step, I got initial prompt about Advanced Privacy when booting into system (“Discover Advanced Privacy”) but fake location doesn’t work properly.

Does anyone know how to install Advanced Privacy on GSI? Is it even possible to install it on 0.23. version of e/os/ or does it have to be newer?

Thanks for your help.

/e/OS v0.23 GSI is an old version from 2022, April 4. The latest version 1.17-q- from 2023.11.10 can be found here
But the Advanced Privacy tool is not included here either.


I just tried 1.17. version and it has AP tool. It works fine, thank you very much for your help.

I wonder why they don’t link the newest version in the installation guide:

Maybe the older versions are more stable? Anyways, problem solved :+1:

1 Like

@Xxpsilon Pointed it out several times, they never changed it. Low prio I guess…

This should be fixed next week. The builds were moved to a new server and post that are showing up as offline. Will have the team resolve this early next week.


That would be great, thanks. Also look forward to seeing T version of GSI, that would expand reach of e/os/ so much as Q is too old to be installed on a lot of unsupported phones.

Although the problem is solved, I am still interested in learning how to install AP tool. So if anyone knows how to complete step 5 from the linked tutorial, please do tell.

@mihi, I still install /e/OS-Q v1.17 GSI today, because better an outdated degoogled dev signed /e/ROM than an outdated tracking StockROM.


I also use it still on a Tablet, the T version looks far far away. Not even sure if my Tablet would support it wlth all the boot changes that happend