Advanced Privacy turned off and still wrong GPS position on FP4

If by restarting you mean a simple reboot, “more” in this regard would be to turn off the phone completely, wait a few seconds, then turn it on again. This can make a difference in general (although over the years and different phones I personally only observed this with different kinds of network hiccups so far).

Doesn’t help anybody with a Fairphone 4 I guess, but on my Fairphone 3 I briefly activated everything in Advanced Privacy to look for obvious effects, then only left the tracker blocking enabled … GPS works totally fine for me.

It could be helpful if anybody posting here would post exactly what is given in Settings - About phone - Android version (tap on it) - /e/ version (can be long-tapped and copied to clipboard).

This way we could perhaps see whether the issue may be build type related (stable or dev) or not.


I have taken out the battery now. After restart, I have checked, if Advanced Security was on. It was off. Still, Maps shows my position in Manila.

I also experience this issue.
Have 1.0-q-20220526188859-stable-FP3.

1 Like

A few steps you can try, in the exact order as described below:

  1. Turn completely your device off and wait 30 seconds.
  2. Boot it into recovery mode (Press and hold both Power and Vol+)
  3. Format “Cache” (don’t format anything else)
  4. Reboot device
  5. In settings => apps section: Clear cache and user data of all apps that need GPS + “microG Services Core”
  6. Then go in settings again => location. Turn location off, wait 30 seconds, then turn location on again.
  7. Go somewhere outdoor, then try again…

Should work again.

Tip: Deactivate advanced privacy on all apps that are using GPS module.


Can you please tell me where to find this option? I was not able to find it. Thank you!

In recovery, scroll down with “Vol -” to “Factory reset”, enter with “power bottom”, then scroll down to “Format cache partition”, then “yes”.
Then come back to the main menu with the left arrow and select “Reboot now”

I can’t find this option. Only format data. I don’t want to enter this option if I don’t know what is behind it.

Oh ok… Which /e/ recovery version are you running? (it’s written on the top of the screen)

With the latest 1.0 /e/ recovery, here are 2 screenshots from where to go…

Do NOT format data / factory nor system partition…

If you don’t have this function, skip it and do the rest in the right order…

Formatting cache is a placebo, that partition is not used by the system at all.

Is it hard to make a downgrade? I mean - without setting up all apps and accounts?

I deactivated my working profile. At least Im not in Manila anymore but always right beside the streets or a few meters away, so navigation apps tell me to go back on the street.


Following operations fixes the problem for me:

  • I went to Advanced privacy > Manage my location and change the setting from “Use a random plausible location” (was near Manilla :)) to “Use my real location”
  • Force stopped and emptied the cache of the apps that were authorized to see my geolocation (in my case SatStat and OsmAnd~)
    Thank you @stanwood :+1:

Didn’t work for me. :frowning: Did you perhaps perform some additional steps?

personnellement, j’ai réglé le problème en modifiant les paramètres d’Advanced Privacy (selon fcayre)
J’ai essayé la méthode de Stanwood mais sans succès.

  • List item

paramètres : Advanced Privacy → Gérer ma position → Utiliser ma localisation réelle.

Je perds l’intérêt de cette sécurité mais j’ai retrouvé mon GPS. :slightly_smiling_face:

Automatic translation
Good morning,
Personally, I solved the problem by changing the settings of Advanced Privacy (according to fcayre)
I tried Stanwood’s method but without success.

  • List item

settings: Advanced Privacy → Manage my position → Use my actual location.

I lose interest in this security but I found my GPS. :slightly_smiling_face:

1 Like

Followed the steps above, didnt’t work. GPS was still way off.
After enabling advanced privacy and setting GPS to real location everything works fine. If I disable advanced privacy again, GPS is wrong again.

My steps:
Deactivating working profile
Deleting cache of apps
Enabling Advanced Privacy with real GPS location

1 Like

On FP3, swap to top left screen and switch off “Advanced Privacy”? It generate a fake random position.
Or go in the options and enable the real position.

No additional steps, sorry. Maybe this bug has more than one cause :confused: