After a reboot, no network anymore

My Phone is a SONY Xperia Z5.
My eOS version is 0.17-20210601117698
Everything was fine since June and today, my phone turned off because it ran out of battery.
And when I turned the phone back on, after putting the SIM card code, no network.
My chip is OK, it works on another smartphone.
But in my eOS phone, nothing.
The Aeroplane is off, mobile data on, roaming on, automatically select network on.
On the top of the home screen, it is displayed that the SIM is locked although the right SIM code was put.
I have tried to reset APNs to default, but when I add manually the APN when I save it, nothing is added in the APN list.
Can somebody help me?

Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone

Do you see your IMEI in Settings/About ?

Hi @smu44 ,
Yes, in settings/About phone/status/IMEI the IMEI code is displayed

Dont know anything about SIMs but there is a setting in Settings > Secutity > Sim card lock.
Have you tried playing around with those settings?

1 Like

Hi @mike_from_ireland,
The SIM card lock item is disable :sob:
Is it normal? Here is my screen (in french)

I would put the SIM in a different phone, disable the SIM lock on the SIM, then bring it back to the first phone and see if it finds the network again.

You might also try setting the preferred network type to 3G temporarily.

1 Like

Hi @Taurus :smiley: :hugs: :partying_face:
Wonderful it works!!! Thank very much.
I put my chip on an old Iphone, went to unlock the SIM lock and went back to my /e/OS phone and the network is on again.
@smu44 @mike_from_ireland
Thank you too.
/e/OS is awesome and people who are building and using it are great


:+1: Génial! You should be able to re-enable the SIM lock now. :slightly_smiling_face: