AFWall+ requires Magisk, which needs TWRP

Hello @all,
can somebody give me advise in the following matter. I’m running Samsung Galaxy S7 refurbished with /e/OS.
Prior to working with the S7 I intend to install the Firewall AFWall+. That requires Magisk to provide the state as superuser.
For installation Magisk needs TWRP.
My problem: Using the recovery mode it is not possible to install Magisk as “Approval of ZIP-file” failed.
After re-start there is the notice, TWRP App Update required.
I tried several times to install the update of TWRP and to instaling Magisk without success.

Hello @mabe, which version of TWRP is installed on your Samsung Galaxy S7 refurbished?

Which TWRP version did you want to update and it doesn’t work?

Hello Archie,
many thanks for your response. The currently installed version of TWRP is 3.2.3-0
The version I want to install is “me.twrp.twrpapp-26.apk” - it should
be 3.3.1-0-herolte.img.tar?!
(Apologize my poor knowledge in detail.)

Are you sure you’re following the official instructions and use the original files?
(Please note that these links refer to S7 model, not S7 edge.)

Yes, I recommend this. I don’t use the official TWRP app. The benefit is too small for me.

  1. TWRP for Samsung Galaxy S7 (Exynos) → twrp-3.3.1-0-herolte.*

  2. Is your /data partition encrypted?

  3. Please downlaod only → here current version Magisk v20.3 + Magisk Manager v7.5.1

  4. Do you install TWRP Recovery via Odin or TWRP with itself?

  5. Do you install Magisk via “adb sideload” or …?

Thank you e.follower for your response and your advise. I’m going to check this and will come back with the results.

Thank you Archie!
I’m going to check this and will come back with the results to the given time

Doing several trials I was not able do succeed.
To your questions:

  1. Download of
    (twrp-3.3.1-0herolte.img.tar was not running)
  2. Data partition is NOT encrypted
  3. First I want to do the first step :wink:
  4. I tried to install directly by itself, means recovery (loudness up+home+power)
    The result is the report: Invalid ZIP file format.
    Do you have further ideas as to what I make wrong?

Are you sure that you have the S7 and not the S7 Edge?
Are you familiar with flashing the recovery using heimdall or did you only try it with TWRP itself?
Are you saving the .zip file on your external MicroSD or on the internal storage?

@mabe, here are things I don’t understand, e. g.

Where did you download this *.zip file? Give me a link!

With which tool did you try to install this TWRP version?
What is the error message?

Which tool says “Invalid ZIP file format.”

Important: Did you make a system backup first?

Thank you very much Exyna for your answer. Meanwhile I fully succeeded in this matter.
Yes, I have the S7, not the S7 edge.
I installed the TWRP with itself.
The ZIP-file was saved in both the internal and the SD card

Once more thank yu very much Archie for your valued help!
Meanwhile the problems are solved. It was very simple by using the twrp…apk without using the recovery mode.
After the update, the system didn’t boot correctly anymore. I had then to update the system in order to overcome this.
The report regarding the “invalid ZIP-format” was in the recovery mode at the black screen.
In the course of all my efforts I visited many sites and unfortunately I don’t know anymore, where I founf the ZIP-file. As far as I remember it was direct at the TWRP homepage. I’m going to find the site and give you the link Archie.
Once more many thanks to all of you for the valued support.