Alarm doesn't work when FP3 is switched off --- after /e/ upgrade

Hello, I recently upgraded /e/ to the following build:
e_FP3-userdebug 10 QQ3A.
200805.001 eng.root.20211027.184504
dev-keys,stable release

One of the two things my phone doesn’t do anymore is that when I set an alarm and switch it off, I always miss the alarm because the phone doesn’t switch itself on in time. What can I do about it?

Thanks in advance


Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone

Do you mean you switch off the display?
Or do you mean you switch off the phone entirely?

If you switch off the phone entirely, alarms will not work then, and this will not have worked before as the Fairphone 3/3+ doesn’t support this (most nowadays smartphones don’t).

If you only switch off the display, and in case your system language isn’t set to English, you might try setting the system language to English and try the alarm again. (Lately there are strange language related bugs, also with alarms.)

1 Like

Thanks for your reply.

I can testify under oath that with /e/ Android 9, my Fairphone 3 could be switched off completely, and it woke 1 minute before the alarm time and then sounded the alarm. I have used it numerous times.

So why is this feature no longer working? Software? Hardware? Compatibility issue?

Thanks in advance and best regards


In this case you might want to contact the developers directly by opening an issue here … Issues · e / Backlog · GitLab.


Check /e/ OS releases 1.2, they have solved the issue according to the release note: v1.2-r · e / os / releases · GitLab

FP3: Power off alarm has been fixed