Alarm when smartphone is off?

Using eOS on a Gigaset GS290.
I’ve set an alarm, switch my smartphone off.

However, the alarm didn’t ring…

Is it a limitation of the OS or of the smartphone I’m using ?

Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone

1 Like

I don’t know. To be honest I wasn’t familiar with such a feature or never thought about it… :no_mouth:

If the feature worked on your phone before, if you had OEM stock ROM, then the OS would be the issue.

Just tried the power on with alarm on all of my devices. Only the OnePlus running stock OxygenOS powered up the phone.
None of the others (Essential, Axon 7, two Motos), running custom ROMs including /e/OS, turned on the phone.

From what I’ve read, some but not all manufacturers include hardware alarm support. Then I guess it’s a matter of whether a custom ROM can make use of it.


Old devices allowed such a use, but nowadays alarm generally can’t switch on the phone. Due to hard or software, I realy don’t know…

The workaround I use :

  • set alarm,
  • enable Airplane mode,
  • sleep :wink:

It’s been a “limitation” in smartphones as long as I can remember (back to Ericsson Symbian days :slight_smile: ). I don’t see it as a limitation: if I turn my phone off, I want it turned off, not staying onjust to wake me up. If I want the alarm to ring, I don’t switch the phone off. Let it go into standyby or do not disturb (but exclude alarms from DND).

I have the same issue…
I’ve noticed that if I keep the wifi OFF when i turn on my phone the timing is always 17:20 of the 1st April 2022 also if we are another day…
I guess this may be the issue because when the phone is switched off alarm can’t ring.

this probably needs hardware support from the phone, but on my FP4 I can configure the /e/OS alarm clock to automatically power-on the phone, when an alarm is set: it needs the additonal permission ‘power off alarm’ and is then able to activate the phone some minutes before the alarm should ring… (maybe the ‘upcoming alarms’ notification must also be active? not sure about the exact term, as I’m using my phone in German)

on my fairphone 3 it works (old eOS version) : it switches on 1 minute before alarm time, and then can sound the alarm.
then I did some OS upgrade, and it still works, but I can’t find the control anymore… pretty strange. I would like to find it though, to use on other phones.

some info explaining that it is not easy but sometimes possible.

Then I guess that if it can work, the eOS could make it available to configure, right ? any clues ?..

by the way, I just saw that it has been fixed for newer versions of eOS Alarm doesn't work when FP3 is switched off --- after /e/ upgrade - #5 by Ceddev

yes by symbian and sailfish os by old devices.
observing the topic here i’m surprised that such function works by newer devices with android with fp3 :slight_smile:
would like to have it by my galaxy s10+

Continuing the discussion from Alarm when smartphone is off?:

Hello, I just installed the equivalent of Android 10 on a samsung J5 2017 and I also have this problem. Has this also been resolved for the equivalent version of Android 10? If not is there a workaround?

This topic was automatically closed after 61 days. New replies are no longer allowed.