All apps on galaxy s9 are deletet after update to android 10, nothing works anymore - NEED HELP!

Hello dear community,

this morning I downloaded the new system update for my galaxy s9 and then while having breakfast I just clicked “install” and didn’t watch any further.
This was obviously a big mistake, because my phone is now not usable anymore.
All my installed apps and contacts are gone, some photos as well.
But the biggest problem is, the system is crashing down permanently every few seconds. I can’t open the appstore or even install a new app!
It looks really bad and I have no idea how to fix this. Any help would be very appreciated.

Thanks so much!

Hi @Kostya1, welcome to the /e/ forum.

I think important to identify was the phone previously on Android 8, Oreo stable, so that this was indeed the “new” OS OTA Upgrade of S9 / S9+ to Android version Upgrade to Android version 10, Q. This was released, as a one click upgrade. Please follow these links to confirm your situation. Was the phone an /e/Solutions purchase? You could report this and ask for advice at

Hi @aibd, thanks for welcoming me and thank you for your reply.

The phone was running on Android 8 absolutely stable, I used it every day without any problems.
I bought the S9 on eBay and installed eo s using the easy installer on my own. I took me a while, since I don’t have any experience in doing such things, but finally everything worked out well. But now, after the upgrade, I have no clue how to fix this issue. Thanks for the e-mail address, I’ll try to get some support from there.

Hello @all and @aibd, just wanted to give a short update on my case.
At some point the permanent “crashing down” stopped, without me doing anything. I was even able to install a few apps, eventhough for this I needed to be very patient because the downloads got interrupted quite a few times.
Today, after taking the phone outside, I noticed the mobile internet isn’t working and I have no idea why. Actually another big thing, after I started to have some hope I would be able to use my phone again at some point.
I really feel lost and have no idea who could be able to help with this. Don’t understand why this upgrade is causing so much trouble…

Unfortunately there has been no official word on an easy fix. Do you know that you can compare notes with other users in a similar poition with this hashtag (which appears under the title of your opening post) #ota-upgrade .

Why was it so dificult? This was the very first time that /e/ has released a method to upgrade Samsung phones automatically from Android version 8 Oreo to Android version 10, Q.

Please also check out #development-updates

Hi @aibd, thanks for your promt response! This is really helping me a lot. I’m sure I’ll be able to figure out a solution for the problems with my phone. It’s absolutely great to have this community here.

Has the helpdesk given an idea at all? or offered an ETA?

Can you find from Settings > About phone the full version information.

No response from the helpdesk yet. But it’s fine, I’m sure they’ve gotta handle a lot.

Do you mean the build-number?

@aibd btw I just tried Settings | System | Advanced | Reset options | Reset Wi-Fi, mobile & Bluetooth…and it worked. The forum ist very helpful :slight_smile:

The most informative is Settings > About phone > Android version : tell me that;
then tap on Android version > /e/ version.

It does not always work on a modern Samsung (I am told) but long press on /e/ version: will copy to clipboard.


1 Like

Thank you; you know this says that you did take the upgrade to Andriod 10 Q, and it has failed in some way not fully understood ?

Are you able to work towards collecting something of a backup in the event you choose to start again if that worst case proves necessary?