All calls come up as an Unknown caller - even when they are in my contacts list!

Hi everyone,

I have been having the issue of all incoming calls being labelled as “Unknown”, not even displaying a phone number. When I call the same contact back using their name and contact details, it comes through to their phone fine. Has anyone else had this issue or know a way to fix it?

Looks like the same issue also affects some users on the stock ROM: Bug: Android 10 FP3 - Unknown Caller

Maybe this workaround also works on /e/?

The solution for now it’s too disable the wifi calling and 4g LTE options

Phone - settings - calling accounts - select sim - wifi calling

Settings - network and internet - mobile network - advanced - enhanced 4g lte mode


This worked perfectly. Thanks!


Thanks for the workaround. Hope this will be fixed soon.

Not fixed in Version 20210129.150423. :sob:

worked for me !
/e/OS 0.19-20211027149872

1 Like

My phone just upgraded to 20220222.015514 and no luck… Pretty fundamantal feature to be fixed I’s assume!