Android Auto on a virtual machine

Dear all,
i read some posts in which it seems that Android Auto is not working. I’ve tried downloading it through aurora, downloading also google assistant, maps and google (which is continously crashing) giving permissions only when the app is used. In fact I’m accepting to have lower privacy while I’m driving, since the car I own as no navigation system but it has Android Auto on a big panel (10"). Well, Android Auto starts-up on the phone, while enabling always the “don’t disturb” option, the car, it’s an Audi, recognizes an Android Auto phone but the Android Auto interface on the car doesn’t show-up. I guess it’s not an easy job to make it work, so I was struggling if there a way to create a virtual machine on which I can start a “full android” onyl while driving. Thanks for your help, M.

I’m using v0.23 on a Fairphone4

Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone

There is this, that I have or test with a vanilla roms but not with /e/.

Thank you so much, it seems really interesting and I’m trying it, but since I’m not a programmer, even if I flashed my FP4 with e.os, I can’t understand how to flash nikgapps… can you, please, give me a suggestion? Merci beaucoup, Matteo.

A small update, I found how to flash the the zip file: I restart the device in recovery mode and, via adb, I sideload the zip file. I’m still stuck since I didn’t find how to flash a modified zip, according to what the xda developer forum suggests. I keep the post updated. If someone has suggestions, he’s very very welcome. M.

I guess the method would be slightly different for Windows – not familiar, but you are aiming to

  • unzip the NikGapps package in a dedicated temporary folder
  • search for
  • open it in a text editor.
  • SaveAs nikgapps_functions_sh_original, and leave it where it was.
  • Reopen
  • follow the instructions to edit out the unwanted passage.
  • Save
  • Find the correct program which will zip the modified package.
  • Zip your modified package with a new name like:
  • Off you go with your “@MatteoV modified NikGapps”

Bonne chance

Thank you for your kind support! What you wrote is exactly what I’m trying to do, but I’m sutck at this point:

“Find the correct program which will zip the modified package.”

Do you have any suggestion? Merci, M.

There is a Microsoft page here to cover that Zip and unzip files

When you unzipped, that produced a folder which you worked in. Edit, We must not double “wrap” the new material. The folder just mentioned was created by you. It is the whole contents of that folder which is to be zipped (excluding the folder itself). Then you can give the .zip a non-original name.

Or am I missing something ? (I am not really certain on this, but I understand that Windows has more than one zipping format – be sure to use a non-proprietary method.)

I didn’t rename the folder, maybe this is my mistake. I tried to unzip and zip with two different methods: windows application and 7zip, bot without success. I’ll try also renaming it, but up to now this is what I get when I sideload:

“failed to find update binary META-INF/com/google/android/update-binary”

So I do not know how the original zip was packaged. Did you already try to install the original by sideload? (To check it is possible.)

You maybe have a different issue with Fairphone 4.

A custom recovery to flash a zip file

Is your original download of NikGapps equipped with such META-INF/com/google/android/update-binary

That is; does it have a structure which includes any elements a bit like this:

$ ls -Ral

The original one is transferred without that error but getting one more error “partition is full”, but I haven’t yet checked what does it mean.

I downloaded the original and update-binary is present. I have reworded my earlier post which I realised was incorrect !

We must not double “wrap” the new material.
It is the whole contents of the folder which is to be zipped (excluding the folder itself).

I am not sure what you have in the way of a Recovery on Fp4. Can you see the size of /system and the spare capacity of that partition from recovery … or can you communicate with adb with the command

df -h /system

Si tu es sous Window

  • install 7zip puis
  • ouvre ton fichier encore zipper
  • ouvre un editeur de texte comme notepad++
  • recherche le fichier a modifier
  • glisse le dans l’éditeur de texte
  • fais tes modifications
  • sauvegarde
  • ferme l’éditeur de texte
    Tu devrais avoir un message de disant que l’archive a été modifié.

Tu utilses quel recovery ? TWRP ou /E/


If you are under Window

  • install 7zip then
  • open your file still zipped
  • open a text editor like notepad++.
  • find the file to modify
  • drag it into the text editor
  • make your changes
  • save
  • close the text editor
    You should get a message saying that the archive has been modified.

Which recovery do you use ? TWRP or /E/

Some steps ahead:

*downloaded an older (July 2021) NikGapps file;
*downloaded notepad++ AND setup as STADARD editor in 7zip (otherwise it wasn’t possible to save the modified file!);
*now the modified zip works perfectly

BUT… I still get an error: it’s impossible to mount partition during sideload. I attach the screenshot taken from the phone where I’m using “e” for recovery.

The message is talking about a log… but where is it located? I’m not able to find it on the phone!

try changing recovery !

is probably a clue that this is beyond the limits of /e/ Recovery.

Logs at /sdcard/NikGapps/logs/Logs-NikGapps-Addon ...

refers to internal storage on the phone. The SD card itself is referred to as /ext_sdcard.

I would expect the Files app to find it listed on the device, rather than SD card.

Thank you. I found the logs in the adb menu on the phone and I read them. I had an error modifying the “if, them, else” cycle. Fixed this error, I get always exit status “1” but NOT for “failed mounting partition”.

Actually the situation of the file is this:

is_on_top_of_nikgapps() {

shellcheck disable=SC2143

if [ “$(grep ‘allow-in-power-save package=“”’ “$system”/etc/sysconfig/.xml)" ] ||
[ "$(grep ‘allow-in-power-save package=“”’ “$system”/product/etc/sysconfig/
.xml)” ]; then
addToLog “- Is on top of NikGapps: $nikgapps_present”
addToLog “- Failed to write $install_location”
abort “Installation Failed! Looks like Storage space is full!”

I should find a way to read the logs OUTSIDE the recovery mode. Can you, please, suggest me a file manager capable of retrieving this file? With the filemanager included in “e” I can’t find it. Thanks again, M.


Was there a difficulty?

I would expect Files app to find the folder NikGapps on the device. I have used Ghost Commander, not sure it will do better. The log when you find it will be the file Logs-NikGapps-Addon ... .tar.gz, which is “zipped” or compressed and will require opening with a suitable application – is that what you are asking for? I never used an Android app to do that.

I would actually just extract the file.tar.gz by adb and open it on the PC.

About space: I wan’t able to find a way to make that command work, but correcting the syntax of the modified file, it seemed that this error disappeard. Up to now I’m also not able to retrieve the log file. I’ll work on it again and update you as soon as I can get the log. Thanks, M.

So I will pass this on … in cased it helps rule out the possibility that space is an issue (as the NikGapps package is quite large at 464MB on my download) ADB Commands - Android ADB Shell Commands Manual

$ ./adb devices
List of devices attached
52xxxxx93	device

$ ./adb shell df -h /system
Filesystem            Size  Used Avail Use% 
/dev/block/mmcblk0p20 2.8G  1.2G  1.6G  44% 

Great help! Actually this is my situation:

adb shell df -h /system
Filesystem Size Used Avail Use% Mounted on
/dev/block/dm-5 1.9G 1.7G 210M 90% /

I’m not getting and space error anymore after correcting the syntax of the previously described file.
I attach the actual logs that I don’t find on the phone (even if I searched them… but I don’t have any NikGapps folder, probably because the installation is aborting).