Any way to use "Login with Google"?

I tried to log into a Webtoon account that I had previously set up on my old phone using the “Login with Google” option, but it just keeps failing. Is there a way to make it work?

Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone

1 Like

Could you give an example of how it’s failing? Screenshot with the error?

It could be something related to network such as using Advanced Privacy’s Hide IP feature which uses Tor. That might hamper Google login. If so, disable Hide IP and try again

Are you using the Naver Webtoon app (huge number of trackers)? Hope not.

Regardless I’d suggest creating a new login with email / password and break that link with Big G.

1 Like

Here it is, no hidden IP. Yeah, I know it has a lot of trackers, but none of them are showing up in the privacy settings.

I realize that I could just create a new account, but I had some “coins” on this one and would prefer not to lose them.

You can login to your Google account in Microg and you should be able to use Google login in apps

Yeah, that’s what I thought, but I’m logged in with microG and it doesn’t seem to be working.

Also add google in -->settings -->account

I did that, too.

It’s strange… I can tap any of the other login options and they seem functional. I didn’t actually test them since I don’t have those accounts, but they take me to a login page to authorize the app. Only the Google option displays an error message.

I’ve also tried removing and re-adding the Google account to see if that helped. It didn’t.

Might be one last thing to check.
In Settings → Accounts tap on the ‘Google microG’ account (white G on blue square).
You’ll find three options that are actually all the same. Choose any.
On next screen toggle on ‘Allow apps to find accounts’ and see if that helps.

At the microG GitHub there was an issue opened up about this last year. A user mentioned Webtoons. No solutions offered though. Haven’t checked for related issues yet.

Yeah, I saw this setting and already tried it with no luck. Thanks, though.

This one issue gixes a theory why the sign-in doesn’t work.

SSO Via Google, Facebook, Apple, Amazon, Microsoft, Etc. Not Working In Third-Party Apps/Outside of GApps (e.g. Gmail, Google Drive, YouTube, etc) · Issue #1882 · microg/GmsCore

Yeah, that definitely looks relevant. I’m not sure how to fix it, though. I may have to investigate further.