App detects device as rooted

Hi,

I’ve seen this so far only with the barclays banking app, none of my other banking apps have this issue. When I run it (installation works fine) it pops up with
“Sorry, the Barclays Mobile Banking app does not support rooted devices […]”
This is briefly preceded by an error message that seems to be
“T0017
Not Authenticated”

I was thinking this, but wanted to confirm with someone that knows their stuff a bit better than me.
Right now “root access” is disabled in the developer settings. To me it seems like Barclays detected the unlocked bootloader as a potential root access like intrusion.
Does that in any way make sense? Please let me know if I a missing something or if anyone managed to get the barclays app to actually work on /e/

Cheers,
Carlos

Hi @Carlos Most payment apps do not work with MicroG - GooglePay is one that I have tried. As you may be aware in /e/ we use MicroG to replace Google Services. Not sure about the Barclays app in case there are users who have tried it they may be able to comment.

Hi @Manoj
Thanks for getting back so quickly. I am about 60% certain its not a microG problem. I have other banking apps installed like halifax, starling, monzo and n26 and none of them have any issues.
Barclays however seems to see the device as “rooted”. They have a disclaimer that the app doesnt work on rooted devices. If the “is-rooted” check runs through some google services, then maybe that could be connected to microG otherwise I think it must be running through some other decoupled things, I might get in touch with barclays about that , I could imagine they are doing something wrong on their end.
Cheers,
Carlos

Please let us know what the response is from the Barclay side. I think it will be along the lines that you are running it on a custom ROM and so on.

hello,
@Carlos did you root your device with the help of Magisk? If so on the top left of the app you have some option, one is great called “Magisk hide”, If I’m not wrong, you can tick on it and choose which app you want to hide your device rooted status. You can try that and reboot your device to see if it works.
I think in the past there was a xposed module called “root hide” which was doing the same thing…

Hi @vlag24

Unfortunately no, I just have /e/ installed, didn’t mess with root access around much. I tried enabling it in dev settings and disabling it again, but nopes.

1 Like

Hey,

I came across this issue back in the days I used LineageOS.

If it’s the same issue the app detects the unlocked bootloader as you mentioned and presumes the devices is rooted even if it’s not.

I didn’t mess around with it but locking the bootloader might be worth a try if possible.

Tom

I had a look at doing that, but so far, thats not an option, I had actually asked about this in a different thread, and was pointed to this thread

I guess so far thats still out of reach, but if there is another way that would be cool

1 Like

You are right @tom This issue occurs in Lineage as well. I think I had tried to lock the bootloader but that did not work. The app still detected that it was installed on a custom ROM. Remember had used Magisk to somehow spoof the app into believing it was on a stock ROM. Since it was a banking app and all this is not exactly safe I did not research it much further!

Check the response given on a different thread here

I also have the problem that one banking app detects root, eventhough i uninstalled Magisk and wiped cache… All other apps work fine and I didn’t have this issue with lineage16+microg before…