App Lounge and FakeStore

Awhile back I wrote about the fact that some apps from the Play Store, in a bid to thwart piracy, conduct a check to see from where they were installed. If the app sees that it wasn’t installed from the Play Store it would popup a message regarding that and not go any further. Usually icon packs, free or otherwise.

To recap, Aurora Store has three installation methods.
Session (recommended), allowing for background installs.
Package Installer. Use the ROM’s foreground installer.
Root. Takes advantage of FakeStore’s presence to make apps think they were installed from the Play Store.

FakeStore has the same package name as Play Store ( and is included with /e/OS, LineageOS for microG (I think), and other such ROMs (again, I think).

So I automatically was going to dismiss the App Lounge figuring it wouldn’t support a similar method. Was surprised to find that’s not the case. App Lounge automatically makes use of FakeStore.

I conducted a test. Searched for an ole favorite icon pack called Ciclo.
First I added my Google account in App Lounge. Found Ciclo and went into its entry. It showed a pay button with price. Tapped on it and was presented with a dialog about going to the Play website to purchase. Nope, not what I wanted to see.

Went back to the search list where Ciclo was at the top. Tapped the INSTALL button from there. A little progress indication, slight pause, then it fully installed. Now the button says OPEN and my firewall asked if I wanted to grant it net access. Good.

Checked the AppInfo and at the bottom it shows it was installed via FakeStore.
Launched Ciclo and was presented with a dialog thanking me for installing from the Play Store.

Overall I would say this is a good thing.

  1. Installing a paid app wasn’t a problem.
  2. Automatic use of FakeStore.
  3. One less reason for root.

Still not sure if I’ll make use of App Lounge but nice to know it was more functional than I assumed.

Do note, Play Store checking is not the same as In-App license checking which is not possible.


I tried following your steps to install the LibreLink app from Abbott. I can see that it gets installed with FakeStore, but it still says it needs to be installed from Play Store and then exits.

What did work was to reinstall the My Renault app this way. It no longer complains that the phone is rooted.