App Lounge fails anonymous access [error 429]

Good Evening,

I had been a /e/OS user for a couple of years now but I’ve never encountered a breaking bug, so I’ve just made my account because I’m facing a big problem right now.
I’ve just upgraded to version 1.9.1 from the official updater, when I try to use App Lounge I’m greeted with a error box that says that AppLounge can’t do anonymous access due to a impossibility to generate or validate the required token or unspecified “other issues”. When I ask for more detailed information the error message reported is: “Validating AuthData failed. Network code: 429 Success:false”.

What is wrong in your opinion? How can I fix it?

My phone is an FP3 currently working on a Wi-Fi connection, which is the same that the desktop PC that I’m using to write this post is connected to.

Hi @CruthABhais welcome to the /e/ forum !

I am going to suggest the following, but please report back if this has nothing to do with your error.

Settings > Apps and notifications > See all … apps > App Lounge > Storage & cache > Clear storage | Clear cache

I am also unable to use App Lounge for the past 2 days. When i open the app it says “Cant connect! Please check your internet connection and try again”. Strange thing is the internet connection on the phone is working fine for other apps like browser etc, plus i have other devices using it. I am on FP3+ on OS version 1.9.1. I tried to clear App Lounge storage & cache as suggested but this did not work for me

Hi @Fraz – perhaps you could clarify

would you describe this as a “straight away” notification or does App Lounge appear to connect to a remote server … wait a while … then send this notification.

If the second, I believe I have seen similar from time to time, where I speculate that the remote server is “too busy” and the response is effectively a “time out” – please try later.

Hi abid, the app opens at the normal starting screen showing top free apps, top grossing apps etc but when i select any of the navigation buttons along the bottom, categories, search, updates, settings I am presented with the cant connect error.

Also, when i try to select any of the apps from the home screen i also get the cant connect error. For example WhatsApp is there but if i try to select it it instantly shows cant connect.

Ahh … I just checked the status page; I think this fits with currently.

1 Like

That would explain it :grinning:

Well, as suggested, maybe it was only a temporary hiccup of the Murena services also for my case.
Tonight I can access App Lounge as an Anonymous User with no problem and I have updated all my apps.

I can mark the issue as solved and this topic can be closed!

I have the same error. Its been like this for at least 2 days. Do I need to do something?

Here is the problem:

I open the app, says it can’t connect in annonymous mode, I can’t do anything about it within the app. I’ve cleared cache and data but it didn’t do anything.

Do you have any part of Advanced Pricacy switched on ? It might be worth switching it off fully, Clear storage in App Lounge and restarting the phone.

I only had tracker. I’ve disabled, removed data+cache, restart. Still get the same error

In my experience App Lounge seems to require a particularly clear line. It is possible that the error is not your end but with the server handling App Lounge, we don’t know from that error code. Meanwhile if difficult to access App Lounge you might consider installing F-Droid and / or Aurora Store: an unofficial, FOSS client to Google’s Play Store.

It may not matter too much with most apps but when using more than one App store it may be sensible to keep a bit of an eye on which store is updating which app.

For the benefit of others: I had the exact same problem, and nothing worked until I upgraded my \e\OS to the latest version (v.1.14). That solved the issue. (sept. 2023, Fairpone 3).

Yes this is due to Google making it more and more complicated to use the API to access the Play Store Data , and it will get worse …

Hi there, I am having the same issue with a moto x4. I cleared cache and data, restarted but didn’t help.
I think that the /e/os version is a bit old (1.8.1) for this smartphone, maybe that’s the reason, what do you think ?
It would be great to get a more recent version for moto x4, I am on 1.14 on galaxy S9+, I’m sure some fixes are needed on x4 !

Then you have to upgrade to Android S, it is available for your device :

Hello everybody,

I am having exactly the same problem for over a week now.
And yes my guts told me it was evil Red Nazi Square Alphabet Inc.
(The evil ones that occupied Google long time ago and the need for /e/OS was created)
But i could not find in this topic a real solution to this problem?
What must i do to regain my anonymous app lounge login token?
Thank you all so much in advance…


I rakkaus murena

(Google translate :face_with_open_eyes_and_hand_over_mouth: :thinking: :face_with_peeking_eye: told me that rakkaus means love in finish where the murena servers are)

Please try Post #2 and do it in such a way as you truly log out, so this will probably mean that you have a clear line to the server at that moment, and when you reconnect after Clear storage you definitely see and accept “Terms of service”.

Edit, furthermore, if the server is busy please be prepared to “try again later”, trying also to guess a less busy time of day or night !

If this fails, please let us know if “Error 429” of the title is part of your problem.

Edit, reworded for clarity, at that time the Status page was showing a “lack of service” warning, that was and the reason this was marked [Solved].

Other #app-lounge threads exist.

1 Like

Thank you for your reply.
I cleared the data and cache.
But 429 came back. [Solved]