App Lounge not loading anything since this morning

Hello,

last thursday I installed /e/os on a new Gigaset GS290. It worked all well, I did some configuration changes like allow flipping the display etc., I set up emails, activated Advanced privacy and installed four apps via the App Lounge. I also received and installed the OS update from 25.07.2022. Haven’t done much more yet. There is still no SIM card installed, all internet access is via WIFI.

This morning I wanted to install other apps to finally move from my current phone to the new one and leave google behind :slight_smile: but the App Lounge kept being blank and after a while said (in German:) “Zeit abgelaufen beim Holen von Apps. Gewisse Netzwerkfehler verhindern das Holen der Apps”. This translates to: “Time expired during fetching of apps. Certain network errors prevent the fetching of apps”. Below this message it said (but I did not take note of the exact words) that I should try to change settings to only search for open source or pwa apps. I did it but with no success.

Internet does work fine for emails, browser and the apps I installed. Just for a test I switched off advanced privacy, I rebooted the phone twice, but now there is not even an error message anymore, App Loungs now simply stays blank. I checked a few times during the day and waited until tonight, kind of hoping there is a server issue and it’s not related to my phone :wink: but… unfortunately it looks like a problem on my end…

What may I have done incorrectly? What might be the cause? What can I do to get it working again? Any suggestion is highly appreciated as I currently wouldn’t know what else to do or try, except maybe a new installation of /e/os and hoping the problem won’t come back…

I’m compeltely new to /e/os and still trying to find my way through it. So thanks for your patience :slight_smile:

BC

Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone

Hi @10111100 welcome to the /e/ forum.

I can understand you thinking “it must be something I did” … but I don’t think so …same started for me Saturday morning. The issue is reported here

It does seem intermittent and we hope for a quick resolution.

1 Like

Hello aibd,

thank you for this very quick reply and the information that it seems to be a bug! I was indeed getting more and more used to the idea of doing a complete new install of /e/os… you saved me from doing it in vane :wink:

Have a good rest of the weekend!

BC

1 Like

reinstall wouldn’t help: Updating apps seems broken - #15 by Art

Besides the OnePlus 6 I use a Samsung 9 with /e/ which is experiencing the same issue.
I prefer f-droid (+ some non-free apps with Aurora store) over /e/ App Lounge - please note: you have to de-install/re-install any apps if switching to/from f-droid store as f-droid builds/signs apk with their own keys.

Hello @Art ,

thanks for the reply! May I ask why you prefer F-Droid over App Lounge? Is it for security concerns (as App Lounge accesses Google Play Store) or is it for different reasons? As I am quite new to this topic, I’m not sure what to think about it that App Lounge accesses Google’s Play Store and I’m trying to get an idea about how much that might affect the privacy gained by using /e/os… I read some articles but so far that didn’t quite enlighen me, therefore I’d like to know if that’s the reason why you prefer other stores…

Thanks!

In fact, it’s not other stores. App Lounge is a combination of F-Droid and Aurora. So if App Loungs is down, using F-Droid + Aurora for the uopdate is the same thing.

2 Likes

I prefer f-droid as source for my main applications because:

TLDR: tradition, laziness and feature completness (for me)

  • f-droid is available for all customs roms. Besides /e/ I’m using GrapheneOS (microG-Lineage on old S2 Tab). I started using custom roms with LineageOS + Gapps (to use Playstore), but switched to Lineage + microG after short time.
  • all ‘my’ important apps are available on f-droid and I don’t need any Google services.
  • I trust the devs behind f-droid: they check on tracking frameworks inside the apps and sometimes deletes those from the source code before building the APK. They offer these services for ages without major issues.
  • I can add additional repositories to f-droid (e.g. Cryptomator)
  • /e/ App Lounge was using a different source for APKs in the past: ?Apptoide/cleanapk? - and I wasn’t eager to (security) assess another packet source/repository.
  • not all apps I’m missing from f-droid were available on /e/ Apps → I had to use Aurora anyways

From my understanding /e/ App Lounge uses the same technique/code as Aurora to access the Play Store → if Google changes something in their API access might be broken for 3rd party app stores for some hours/days → it never was an issue for me - you simply have to wait a bit.
It might be annoying for you for finishing the basic setup of your device, but later it doesn’t matter (to me) to get the latest version now or in 2 days (and in f-droid you often have to wait for over a week to get the latest version).

2 Likes

Hello @Art

thank you for this extensive answer and the explications! Sounds good and time is no issue, just as you said. I will consider changing to F-Droid and Aurora as well :slight_smile: Seems to be a good moment for that, because as you wrote I’ll need to re-install all apps, and so far I have only installed a few apps as I am just starting to set this phone up… :slight_smile: Thanks for the advice!

I have always used F-Droid and Aurora Store rather than App Lounge or its predecessor Apps because

  1. They are both mature apps which are FOSS, well supported and maintained, and which have most of their bugs fixed already. Apps and App Lounge are new apps which still have plenty of outstanding issues, most of which were fixed by F-Droid and Aurora Store long ago.
  2. Apps and App Lounge did / does very little that F-Droid and Aurora Store do not do. For me they are unnecessary, and a distraction for /e/ developers from the main task of developing the original parts of /e/OS
  3. Apps and App Lounge source(d) some or all of their apps from an anonymous web site called cleanapk.org which claimed to get its FOSS apps from F-Droid, but would not say where they got the non-FOSS apps. I prefer to use apps and web sites which are transparent about such things
1 Like

Thank you @petefoth for your reply. Especially the last point, the intransparency where the non-FOSS apps are coming from, is a strong reason for changing.

Apps used to source from CleanAPK, but the new App Lounge source form F-Droid and Aurora, as far as I know.
And in App Lounge, it is said if the app is FOSS (source by F-Droid) or not (source from Aurora).

1 Like

So you’re no better off using the two stores separately than using App Lounge…?
Yes, I saw the message “Open Source” in some of the apps…
Thanks for the advice, @XjFred

Well… It’s up to you.
One app is better than two, as long as it works. Obviously, it doesn’t, so I switched back to F-Droid + Aurora.

1 Like

One thing in particular going for App Lounge is the inclusion of a privacy indicator from εxodus.

Having selected an app in App Lounge this is included in this form

App Lounge does not seem to direct link to the exodus report, but one can bookmark the above link, then look up an app if you are uncertain of the two indicators reached from pressing the > against Permissions / Trackers.

Screenshot_20220801-134048_App_Lounge

Screenshot_20220801-134104_App_Lounge

1 Like

Hi @aibd

yes, yesterday I read how this rating is calculated. I didn’t know, however, that it is taken from εxodus - until now I hadn’t heard of εxodus at all. I thought it was calculated by App Lounge itself.

Had a look at the link you provided for εxodus. Very interesting… the first app I entered came back with 9 trackers and 16 permissions. I was only aware of one permission… really very interesting and useful site. Thank you for this info!

1 Like

You’re better off because the two apps have fewer bugs than App Lounge :wink:

1 Like

As I understand it, App Lounge gets the non-FOSS apps direct from Google’s Play Store (as Aurora store does), not from Aurora Store