App Store Not Available?

I have installed /e/ on my Fairphone 3.

I can acces the internet using teh browser.

When i try to open the App Store i get “Something went wrong!. Please try again later”.

I then tried to get to the F-Droid store and that site is unavailable too.

There are several apps i need.

Do i need to reinstall something? How can i get apps on my phone?

Thanks for your help


Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone

There could have been an issue with the app at the time when you tried. Pl can you try again now. Also when you get the blank main screen you can try a search and type the name of the app you want, that work at times. There are some chinks in the App Installer / App Store which still need to be fixed. If you tried FDroid and that is also not working this issue could be different. FDroid takes some time to refresh its repositories before the first run.

You’re right. The app store is slowly starting to work. Perhaps it will fully resolve in time. Thanks for your help.


I didn’t have any problem last week but today applications are being downloaded very slowly in Apps (like 100 ko per minute) even on Wi-Fi and then it suddenly stops.
Is there an issue going on?

There seems to be an issue with App Store at the moment. The team is looking into it and will update.

Ok thank you @Manoj !

It’s working again :hugs: Well done :+1:

There was an issue on the servers with some processes getting stuck and occupying all CPU resources. This got resolved. Closing thread as issue got resolved.

1 Like