App store - Something went wrong! Please try again later

Hi everyone!

Installed and configured /e/ OS on my phone yesterday and then I wanted to install some apps.

I began with telegram, the icon appeared on the home screen. But before using it, I decided otherwise and uninstalled it (probably doesn’t matter but just in case it does).

Now each time I visit the app store it says: ‘Something went wrong! Please try again later.’
Doesn’t matter whether in Home, Categories or Search tab of the app store.

Considered there might be some technical issue with the app store on a global level, but as neither /e/ foundation or any user didn’t mention anything and the issue is still present 12 hours later, I guess it is due to my device.

A factory reset had no effect. Can somebody help me out here?

Thanks and have nice day! :blossom:

It’s probably not the device. All app stores have down times or other network problems. Try an anti-cyclic time, early in the morning when all other people sleep. It’s not unusual that you can’t reach a server also multiple times after each other.

Try clear cache and app data. You never know 🤷

Hi irrlicht, Hi awopbob,

Storage and cache were cleared, but the app store still doesn’t work.

I’ve been trying many times. Didn’t work last night, didn’t work this morning and now it still doesn’t in the afternoon. Tried every now and then in between. The app store being down for the last 16 hours and no one mentions it? Unlikely.

Thanks for your replies!

Edit: the phone has a connection to the internet

No, the app store isn’t down at the moment. My Apps does connect without any problem.

Problem got fixed.

For anyone having the same issue in the future:
The date and time of your phone needs to be correct.

johnny :upside_down_face: