App switcher not working

I use /e/ os 1.2-20220725206061 on my Fairphone 3. Since 1.1 the app switcher is not working anymore. Fortunately I have the KISS launcher installed which provides some help. I’ve already filed a bug report on GitLab, but when I tried the new 1.2 /e/os today, there was no improvement. App switcher or app history does simply not work - the button on the right side does not show the app switcher menu and the app switcher cannot be linked to another button. Could this issue have to do with the KISS launcher? Or has the app switcher been removed by design?

I am not quite sure from your report if this is the correct approach … one might look at this as an issue with the launcher; /e/ uses Bliss with help from Trebuchet to enable the horizontal swipe for Recent apps.

Please try

  • Settings > Apps and notifications > Show all > Top right 3 dot menu > Bliss Launcher > Storage & cache > Clear Storage | Clear cache

  • Settings > Apps and notifications > Show all > Top right 3 dot menu > Show system > Trebuchet > Storage & cache > Clear Storage | Clear cache

Be aware that simply Clear cache might solve the problem, while Clear storage is more likely to be the solution.

In the case of Trebuchet, you might as well go straight for Clear storage.

In the case of Bliss when you Clear storage you will lose some data and settings in the Home screen, most noticeable being rearrangement of your icons.

Thanks for your reply. I’ve tried both approaches - with no avail. App switcher still not working.

In order to further define the problem I wonder if it it worth using the Search function in Settings and experiment with all the permutations of Navigation bar? Or is your issue definitely not there either?

Thanks. I’ve tried it - to no avail.

Is it worth eliminating that possibility by uninstalling Kiss, clear caches again, reboot and retest?

I removed KISS, cleared storage and activated Trebuchet. That did the trick! The app switcher is back and also KISS runs again, after reinstalling it. Thanks a lot! Bliss is now completely gone and I can do without it.

I would be interested to know; how did Trebuchet came to be disabled?

If I disable Trebuchet I can reproduce your initial post. When I enable it horizontal scrolling returns.

my conjecture is that running Bliss needs to deactivate Trebuchet.

My understanding is that in /e/ Bliss requires Trebuchet. ( I am running Bliss only on this device.)

Well, after removing KISS, Bliss appeared again and I found Trebuchet deactivated. I tried to activate it - and voilà the solution!

1 Like