Apps can't establish internet connection when Advanced Privacy enabled

With advanced privacy enabled none of my apps can connect to the internet. When loading a page in brave browser the browser fails to fetch the DNS. Signal doesn’t fetch messages and so on.

The “Real IP” in AP settings is stuck in infinite loading.

I assume that AP is not supposed to work like this…after all, disconnecting from the internet would have the same effect.

Any help?

Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone


There is an opened issue on this topic:

Selecting a random country instead of a specific one did the trick for me. I very rarely lose connection now, but when I do a reboot of the phone makes it work again.

1 Like

I have FP4 and tried different settings to get the internet connection working with certain apps, but nothing worked. Random location, certain country, etc, but many apps not working at all as a result. :frowning: Only able to connect when advanced privacy is not enabled. Any other ideas how to manage that without letting trackers through? Or just manually switching off for the time of using the apps?
Could not even call someone through Telegram app, could not establish a connection for something that I thought was quite secure connection.

First of all you could use Advanced Privacy with just the trackers blocked (general toggle on, real location and real IP used).

Then you could try to activate location spoofing and see if you lose connection. If not, then it’s “Hide my IP” that provokes your connection loss. If that’s the case then you can unselect apps that you want to work (although I have a FP4 too and it works for most of the apps, the important thing for me being to activate the feature for the browser app).

1 Like

Thank you! Tried to toggle both and it is the IP address hiding as the issue. Found a happy medium. Thank you!