"apps keeps stopping" every couple minutes

I installe /e/ on Saturday, and since Monday I get all the time those popups about the apps app stopping, afaik this means, that the “apps” app crashed. I’m not using it, i’m using other apps at the moment. I’m not using “apps” at all, installed fdroid instead.
So for me it seems “apps” is permanently trying to run in background, but fails. How can I get further information, why it crashes?
Does anyone know what I can do about the crashes?
Thanks in advance

can you detail your device and version you’re currently on (in settings, with timestamp + android version) ?

For the crashes, if you can get a logcat from adb that mostly shows the reason, but if you’re unable to create one, don’t worry. Resetting the cache of a crashing App can sometime help (Setting → App → Show system Apps → …) or rebooting

Device is SM-G960F/Galaxy S9/startlte, whatever you like :slight_smile:
buildnumber is e_starlte-userdebug 10 QQ3A.200805.001 eng.root.20220124.103652 dev-keys,dev-release
Is this what you wanted? or some other version.

For the beginning, clearing the app data helped. Let’s see if it’s permanently, or if the chrashes come back.

On the other hand, I’m wondering, why there were app data at all, as I never (actively) used/launched the app. Does it run in background?
And coming from Lineage OS, there was the possibility to disable most unwanted preinstalled apps (mail, calendar…)
On e, that’s not possible, the disable button in the app info screen is disabled. Also true for apps app.
What’s the rationale behind it?

If crashing starts again, I’ll try to get some logcat. Tried your suggestion without fetching logs before, sorry.

another thread points to a still open backlog ticket for foundation.e.apps crashes at APP app crashes - #14 by lionel.smith - I doubt it is still the same exception, but to cross check when you can capture a crash in a logcat - /e/ Apps Store Crashes (#1293) · Issues · e / Backlog · GitLab

hm, the description sounds very different.
But up to know no further crashes, so no insights.

Thx for your tip with clearing the app cache, I will come back to it, when it happens again.

If it helps my S3 19300 just would not enter apps at all internal or external apart from a couple through APK. As it was it was unusable so I bought a Samsung A51 which I requested to be added to /e/. I keep checking to see whether it has yet. I have de-googled as far as I can the A51 but Samsung are closely linked, not ideal