Apps update issue

Hi everyone!
I use /e/ in a good old MotoG and I have installed Aurora Store too.
Now Aurora gives me 5 updates that Apps doesn’t have, and all the apps are present in the store:

  1. CloudBeats
  2. Magic Earth
  3. Moovit
  4. NetMonster
  5. Signal
    It’s not the first time, sometimes some apps were just a little late than Aurora but this time the delay is starting being huge.
    Anyone with the same problem? Someone can provide informations about it, please?

PS: Aurora Store shows me also a microG Service Core update, is it safe or it installs on my smartphone some Goolag piece of code?


I have the same things with Signal ans Magic Earth. I also have some apps which have updates with Aurora but never with Apps.

About MicroG, it seems to me that the update from Aurora doesn’t work.

Hi @zxs48k,
Welcome to

an application installed form a store has to be uptaded from the same store because of the apk package spoofing signature.

The /e/ app-store is under refound process for now and a V.2 will come soon.

micro-G delivered with /e/OS is patched and signed by the /e/ development team and is uptaded combined to the around weekly OTA system update.

1 Like

Hi @zxs48k there are some issues with the Apps Installer which should be fixed in the next version that will be released. No ETA’s on that.

Thank you all for your kind (and fast) reply! :smile:

Two useful confirmations for me, (I really didn’t remember quite clearly) thank you!
That’s why I didn’t try to update from Aurora, I use this store as little as I can, only if I really need apps that I can’t find on Apps or F-Droid.

Good to know, so I’ll wait for new version (Hoping that /e/ will still support MotoG 1° Gen.)

I definitely have to make an account on Mastodon! :grin:

Hi all, see /e/ application installer V2 is coming soon in /e/OS

I cannot upgrade with both Signal and Babbel.


1 Like

For Signal I suggest you see this post here
Babbel use Aurora Store (Current version 3.2.8) to update it.

I’ve just upgrated to /e/ OS 0.9 but I’m still unable to update my applications with Apps (ratings are back). Is there an issue tracking about this bug? It has been going on for months and is starting to be problematic.

Use Aurora Store to update apps for the time being. Or F-droid if they are open source

I already use F-droid for open sourced apps. What about privacy with Aurora Store?

Its the same version of apk’s as you would find in ‘apps’ or google play store. Aurora is essentially a anonymous ‘proxy’ as such to access the google play store.

If you can’t update with Apps applications installed by F-Droid, that’s normal since they don’t have the same signature.

I was talking about the applications that are not available on F-droid. But thanks for the clarification, I didn’t know this specific point.

1 Like

Hello everyonel!
So Apps still doesn’t work and I have had to upgrade some apps like Signal from Aurora Store (luckily no problems till now).
But I get no OTA upgrade and it seems that my good old MotoG 1° gen. is abandoned :sob:
Of course I don’t pretend an upgrade to Android 8 (it would be amazing :smile:), but at least an update with the new working version of Apps (V.2) would be great. Is it possible?
Long live and prosper :vulcan_salute:


At least three bugs when I tried to upgrade my apps:

Cannot upgrade ICSx5 and Simple Contacts Pro, I get one file in my downloads as failed after each try of upgrading one of these apps. Other apps upgraded correctly. Haven’t installed any other app stores.

App behaviour is unstable: crash on phone orientation change and on split screen.

When upgrading apps there are index bugs: tap a button to upgrade an app and the button of the app above will display the same progress status…

A few issues are opened about Apps. You could look for the one that matches the behaviour you face and add a comment with some logs. Or open a new one.
With this method. Or this one in case the first one is too complicated.

1 Like

Thanks, will see what I manage to do.