Asus - Zenfone 6 (ZS630KL) - I01WD - Documentation Suggestions

…Enter suggestions to improve documentation in this category. Do not raise bugs or issues here…

Hi everyone,

I had some difficulties installing /e/ on my Zenfone. And I found the wiki quite disturbing (no blame here, they have lots of device, it is probably auto-generated …) so here is how I managed to do it.

DISCLAIMER: I am not an expert, it worked for me but I don’t fully understand how. If it breaks everything for you, I won’t be able to help you, so take some time to read and understand what you’re doing. Read everything first, it could prevent hard breaking your phone. During the process, all data will be lost forever, backup is love, backup is life.

If you broke everything, try this:
It worked for me (like a few times…) to come back to a Android 9 working device.

FIRST: you need to install adb and fastboot. The wiki is good enough for this. My tip: use a Linux. A sh*ty old Linux running on a PC that belongs to a museum is far easier to get ADB and Fastboot to work than any cutting edge Windows.

SECOND: Unlock the boot loader. Again the tuto is good enough.

THIRD: you need to get a Android 10 version on your phone. I recomand the UL-ASUS_l01WD-ASUS-19.1810.2011.18, not because I tried all of them, but because it worked for me. 3 possibilities:

  • you’re already set up, congrats, you rule
  • you’re on android 9: download the Firmware on the Asus website and copy it in your internal storage. Reboot, and the phone will recognize the update. If it crashes, it’s probably because an intermediary update is necessary. Try older builds until it works.
  • you overshot and you’re on Android 11. This is more complicated. You’ll need TWRP. Download the last version of the image (img file, not the zip one) and reboot in bootloader. Temporary boot to the recovery with
    fastboot boot YOUR_IMAGE_FILE.img
    Go to wipe, and tap format data. Type ‘yes’ and trash all the data. Return, go to Advanced wipe and wipe Cache and System. Swipe to Wipe. I don’t know if it’s necessary but I did it for both the A/B partitions: to do so press return to the main screen, tap Reboot and switch partition. And wipe everything again. Then on your computer:
    adb push /
    Don’t forget “/” in the end of the command line. Then on the main screen tap Install. Up a level till you reach “/”. Look for you build file, and swipe to install. Again I don’t know if this is necessary, but I installed this build on both partition (the same way we wipe data on them: Main Menu -> Reboot -> select the non active partition). Back to the main menu, Install -> find the firmware -> swipe to install. Reboot. You now should have an Android 10 running on your device.

FOURTH: Download 3 files:

FIFTH: Reboot to bootloader. Flash the custom recovery with
fastboot flash boot CUSTOM_RECOVERY_IMAGE.img
from the fastboot menu, use the volume key to select Recovery and boot in it using the power key.
Go to Apply update, then Apply from ADB to begin sideload. On your computer, use this command
adb sideload
There will be a warning on your phone, this is expected, accept and tap continue.
Back to the main menu, tap Factory Reset, then Format data / factory reset and continue with the formatting process. Then back to the main menu, Apply update, then Apply from ADB to begin sideload. On your computer, use the command
adb sideload

You can reboot, it should work, I guess, it worked for me.

Take care,



1 Like

This really helped me with my also unsuccessful per wiki installation endeavours.
I would just like to condense it to the one point that makes the difference

Upgrade to Android 10 before installing

That is it. No more needed. Just enjoy and thanks to all the e-devs.

Another side note for the newbies, because even unbricking took me hours:
The flashall script/cmd is inside the package. One needs to unzip that package and run the script.
(Me beginner tried sideloading the zip like the os, or fastboot flash it, which …).
The note pertains off course to the link to unbrick on xda above.

1 Like

@rubydesign Thanks for sharing the info.

Can you also try installing the stock camera app and see if is working in eOS? If you don’t have the APK handy, you can try my copy: 19.22 MB file on MEGA

The camera that comes with the os (the one you can’t un-install, i thought we were beyond that) works ok. I have tried OpenCamera before, it is a bit clunky, but works. I don’t know what the apk you sent is.

On the whole the phone works fine. Apart from the random crashes, maybe 1-2 a day. I bought the fone because it said zero issues, but find these random crashes to be enough issue that i’ll switch to a samsung s9. In the hope that works perfect. Can’t go back to google android off course now that the genie is out the bottle. (all those trackers blocked!!)

1 Like

Same, but it wouldn’t have the same post-processing as the stock camera app, so the image might look worse than usual.

It is the stock ASUS Camera app that I backed up from my stock device before flashing a ROM.

Wow, that’s a lot and it is definitely not stable. By crash do you mean normal app crashes or does the whole phone crash?

I agree, maybe you can try the latest beta version of Omni ROM, maybe they fixed the issues I was experiencing, and even with the issues it was fairly usable, I want to switch because I don’t get updates anymore. It even comes with the stock camera app out of the box.

want to add a new more things:

  • camera hdr stopped working. Off course hard to tell if it worked, but i thought it did
  • still 1-2 random crashes per day
  • half the people i call report bad call quality, usually echo, sometimes screeching. Which only goes away on speaker (which off course is unpractical in many a situation)

Not really usable as daily driver. Tried to report the issues so at lest it would show up on the devices page. Bit can’t create an account with my email (dot fi, i don’t know why it doesn’t like it)

such a shame, nice phone, great os, bad combo ;-(
(trying oneplus 7 next)

Can you elaborate more on this? Are there any patterns? Does it crash when you are actively using apps? Did you root your device and install any root apps?

Getting an error message in new ID creation on /e/OS Gitlab?

No patterns.
And I don’t know how to read or even find logs.

Thanks for the account link. A bit sad, but I sent a mail.

How does it crash? Does it just shutdown/poweroff or reset?

There are apps for this in F-Droid’s play store, just search for “logcat” and see if you can find a suitable app. I think root is required for them to work.

Thanks for the help, got the app, learned about adb logcat, great.
Also got my account, thanks @aibd and files issues

But didn’t manage to mark them with the label to show up for the fone’s issues. Still.

It feeezes, i have to restart it, further discussion at the issue if possible

May I suggest you edit your Issue title to include Zenfone 6 and IO1WD.

Within the issue under Device model perhaps edit that to add IO1WD (the device codename) – as you type IO1WD you should see the text become highlighted thereby adding a tag. Other tags should become added by moderators.

Regarding “Device rooted”; if you simply followed the install instructions, the answer is “No”. (Unlocking the bootloader is not rooting.)

The logcat is likely to be very long! Devs prefer to see a whole logcat. A good way to share your logcat is to use a pastebin service like and then add the url of your saved “paste” in the Relevant logs (adb logcat) section.