Asus Zenfone 8 Vendor Image v11

Hi Folks,

Im coming from Sailfish OS and want to give my new Asus Zenfone 8 a new /e/ os home, that I got on sale.

Reading through the issues for this phone, there seems to be a discrepancy with Lineage OS <> /e/ OS fastboot, vendor image versions, due to the currently different supported Android 12 <> Android 11 base firmware.

As my phone still has the Asus Android 11 stock firmware on, in my view, the current /e/ still should work.

Any hints how I can get the old vendor_boot.img for Android 11?

This issue should theoretically be resolved. The install docs for the Zenfone 8 now have it listed for Android S (or 12), so there shouldn’t be a mismatch between the Lineage OS and /e/ OS pieces.

I haven’t tried it myself though, so I can’t be completely sure.

Hmm thanks. Sake installation instructions still talk about Android 11.
Before following these instructions please ensure that the device is on the latest Android 11 firmware.

But, when I look at 1.6S DEV image in the PB files im reading Asus/WW_I006D/ASUS_I006D:12 with probably indicate Android v12

This is a bit confusing to me.

Hi Have you read these yet ?
the file is still there

I think you really need to go to A12 first:
(at the bottom of the page are the instructions)

and then follow the installation manual but use my vendor_boot file
I did it this way and it works

you can try vendor_boot file from the manual but that didn’t work for me, none not the latest and not the oldest (I don’t remember the dates)
I was lucky and had kept my worked vendor_boot file at the time. This is in my dropbox and you can try then.

let us know how it goes

Thanks for the advice.

The thing is, a couple of days ago, I got a bit overexcited on getting the vendor boot image for version 11.
So, I went ahead and dumped the boot image with ‘dd’ - basically extracted the boot image from my phone using TWRP. Then fast booted - flashed this one, followed by the recovery-e-1.6-s- image.
Now im stuck at the boot loader.
I need to spend a bit of time (hopefully this weekend) on fixing this issue first. Luckily, I still can adb fastboot the phone.

Many thanks for your help and sharing your experience with the Zenfone 8!

I finally managed fixing the phone and applying the /E OS v1.7 sake successfully.

Here is what I did the get it working:

  • First updated and reverted all the stuff that I did by applying the Android 12 Full Firmware from the beta site in fastboot mode. (a real life saver)

  • Then updated with with offline installation method to latest Asus Android v12, by dragging the zip file in to the phone home root folder location.

  • Fastboot and flashed your provided vendor_boot.img. (I tried with two current older versions from LineageOS, but got the same ‘denying OTA because it’s SPL downgrade’ errors)

  • Fastboot and flashed

  • Then sideloading the, and accepted the ‘Signature verification failed’

  • Rebooted done!

Only question that remains, why is /E foundation not retaining working vendor images on their server?


Hi @demux ,
Can you please give more details about the process please?
I received my Zenfone 8 under Android 13.
I didn’t saw your post before start Installation guide (Install /e/OS on a ASUS ZenFone 8 - “sake”)
And now, I’m blocked because eOS1.7S is considered as a downgrade…
Which vendor_boot.img do you use ?
Big tanks in advance !

I finally managed to install eOS-1.7 :smiley: :partying_face:
I first installed TRW instead of eOS recovery img.
I managed to flash eOS-1.7 with error messages but it worked and I was able to boot correctly.
I then redid the installation via the recovery of eOS to be sure not to have problems for future updates.
The installation went well without any error message.


ok great to hear, that you might found an easier way of installing it with TWRP. I did not try it this way.
Meanwhile, I’ve installed TWRP at recovery partition, I what to perform backups this way.