Attempting to upgrade Terracube 2e from version 1.0 to 1.1 (2020 model)

Attempting to upgrade from version e-1.0 to version e-1.1. I have developer options enabled. I have enabled usb debugging. But there is no oem unlock option available. When attempting to use “adb reboot Bootloader” to unlock from computer, Bootloader option does not show, only “recovery”, “fastboot” and “normal” options show.
What can I do?

Hi, No answers, but thought I would make you aware of other discussion in this forum along the same lines. I am in the same situation and am sitting out 1.1 until I have some confirmation it is fixed. If you look here, another 2e 2020 user with /e/ was told that they were resolving bugs, but they are so behind on it, maybe they will just release it as 1.2 now? There is also perhaps a problem with the updater, but I cannot parse where they are in resolving the problem. I think I will submit a ticket to support, and suggest you do as well.

Thanks much for your comments. I think I’ll just sit tight for now.

The rest of the phones are on 1.4 now – WHAT GIVES? This is a Murena phone, sold by /e/, why is the support so low-priority?

See this entry in the Gitlab – we may need to do an ADB sideload? I can do this with instructions, but I worry about those who can’t. Can instructions please be posted to do the sideload, even if you are still looking for a way to avoid having to do that to fix updater. If we do the sideload, will subsequent updates be available through the updater?

1 Like

I suggest for a purchased phone that you contact to find the recommended fix.

If you have /e/ installed, you should use the “recovery-e”

Already tried support with their response being: “wait a little longer” but that was before the GitLab entry, so I should probably try again.

I just contacted helpdesk again, requesting sideload/flashing instructions to fix the problem, but I’m not holding my breath - a gitlab user requested the same on gitlab and nothing has been posted there in the 4 weeks since the problem was identified, and the only thing that has happened with the bug is some administrative shuffling/classification. Still Priority 2.

I have /e/ installed (it’s a Murena phone), I have installed /e/ myself on earlier phones (so I know I have the skills), but I still want them to post clear instructions:
1 - because this is to fix a problem, not a normal install, so I want to be sure it’s done correctly.
2 - honestly, I think Murena needs to take some responsibility for this. I don’t want this to be on me if it goes sideways.

The second point is (I’m guessing) why they’ve not put anything out, they don’t want responsibility for this (and to be fair, it’s probably not their fault). But as a purchaser of one of their very few phones that they actually sell, I’m still feeling abandoned. My phone still works, but will occasionally have little glitches of the sort that have been solved in the past by updates, so I’m left wondering.

1 Like

It feels very reasonable to ask on the Gitlab for specific instructions to overcome this issue.

In adding to the post please give the full build details of your build including stable / dev build as revealed by

Settings > About phone > Android version > /e/OS version > Long press to copy to clipboard.

Perhaps also worth stating the version shown on /e/ Recovery.

It looks like a workaround fix is in the works. They will send out SD cards and detailed instructions. @alexis, since you seem to be in charge of this, I wanted to volunteer to help. I have installed /e/ on other phones before and would be happy to troubleshoot the instruction package using my phone, if you would like another set of eyes/hands.

1 Like

@Knuckles We have indeed identified the issue and have a fix.

Option 1: We can share the instructions if you know how to update via sideload.

Option 2: We can share the instructions to update via SD card or send you a SD card.

Let us know.

Best regards.


Yes I can do side load. Please send instructions. I will do not soon but will do. Thanks so much.

I will also do side load, thanks, unless you’d like me to troubleshoot the SD card method.

Hi Alexis, I also just noticed that v1.5 has been posted on the updates page for 2e, and that it has appeared as a download option in my OTA updater (screenshot below). Is it recommended that we try this, or should we wait for sideload instructions?
[edit] - Ah, I think it was automatically included in the updates for all phones, then taken down. It’s no longer there, which I interpret as /e/ not endorsing its use.

@ecs @Knuckles

Here is the process you can apply:


  • A backup of your phone’s important data on an external storage device (optional, but recommended).
  • A phone with at least 50% charge.
  • A computer with adb installed. How to setup adb?
  • A functional data cable to connect your phone to your computer (A charging only cable won’t work).
  • Download all the files mentioned in the download section.


Updating /e/ via recovery

  1. Download the OTA with the hotfix (See downloads section).

  2. Reboot into recovery mode:

    • With the device powered off, long press the Power button and Volume up button together, until a text menu appears on the screen.
    • In this menu, the Volume up button is used to navigate through the options and the Volume down button is used to confirm a selected option. The selected option is indicated by an arrow <<==.
    • Select Recovery Mode using the Volume up button, then use Volume down to confirm the choice.
  3. Sideload the /e/ .zip package:

    • On your phone, select “Apply Update”, then “Apply from ADB” to begin sideload.
    • On your computer, sideload the package using: adb sideload <path to OTA zip file>.

    NOTE: Normally, adb will report Total xfer: 1.00x, but in some cases, even if the process succeeds the output will stop at 47% and report adb: failed to read command: Success. In some cases, it will report adb: failed to read command: No error or adb: failed to read command: Undefined error: 0 which is also fine.

  4. Once you have installed everything successfully, click the back arrow in the top left of the screen or swipe back as the android gesture, then select “Reboot system now”.



It worked great, thanks. The instructions were good for someone who’s done it before – here are some ideas for additional information you may want to include:

  • I think it would be good to have examples/recommendations for where to put the update file so that it’s easy to point to in the sideload command (I just used the Download folder in my Linux laptop, ~/Downloads
  • You should probably mention that it takes a bit longer than a normal upload, and it’s more difficult to monitor progress. Mine “hung” at 47% as mentioned, but it ran for at least 5 more minutes before completing without error. I had experienced this before, so I knew to just go have a beer, but this is not obvious.

Thanks again, great work! If I understand the hotfix, it should allow OTA updates for all later updates, correct?

1 Like

hi @ecs , you will receive proper updates via OTA going forward.


I’m new at this so I need to know, do I need to unzip the files first, or will the side load do this automatically?



UPDATE: Not new to Linux, but to ADB. To answer my own question, no, I did not need to unzip the OTA file. I was relieved to find that the install worked flawlessly.

I installed this file:, saved to my DOWNLOAD directory.
Once I got ADB started, it was downhill from there. I did have to use a USB-A to USB-C cable to get a good connection.

I observed at 47% these messages on the Teracube:
“Patching product image unconditionally…”
“Patching vendor image unconditionally…”
“Patching system image unconditionally…”

A few more messages, then it stopped. I did not see any back arrow, but I hit the power button and it rebooted to the new update, 1.5. It all looks good and I did not lose any data, nor did I have time to crack open a beer.

Thanks to all for the above instructions.


1 Like

Hi @HMartin happy to read that the update worked! You can still crack open a beer to celebrate :rofl: