Aurora Store, different outcomes on different devices

I have two S9 phones, I am trying to install an app on both phones from Aurora. One phone downloaded and installed the app fine, the other gives the error - Install Download Failed App not purchased.

This is a free app.

I tried deleting and reinstalling Aurora, turned phone off and on, reinstalled Aurora, but still the same outcome.

Any idea why one device can install an app, yet another cant.?

Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone

Now there is an update to the app. I got the same error when trying to upgrade, I deleted app, but now get the same error when trying to re-download.

Managed to get the penultimate version of the app on both devices using APKPure. Not sure what the problem is with Aurora store.

This looks like a UK Radio product! So that is probably the clue - Aurora can be deliberately selective with Geo-location (ditto Google), so you may have your phones set differently for that. :slight_smile:

Aurora Store, geo-restricted apps, and anonymous logins

1 Like

Maybe your batterie is to low… :wink:


1 Like

Thanks, I have responded to that thread.

The insecure anonymous session will allow me to see all apps available, rather than just those in my area.

Battery too low, I spend too much time on the phone, I need to get a life. But this activity does provide a welcome distraction from the C word.


Strangely the insecure anonymous setting doesn’t allow me to see the app I am having problems with (even after closing Aurora, reopening logging out and in, rebooting phone).

anonymous means only that your are natted behind a fake account.
If this fake account registered in a area which is geo blocked by the app, then it could not work…

That’s how i understand the priciple behind aurora…

If it is geo-restricted then you need to setup location spoofing as described in this post