Aurora Store - don't install v4.0.2 update

There is a problem with geo-restricted apps in v4 see this post

If you have installed Aurora Store from F-Droid, you may see that a new version (4.0.2 Added on 24/03/2021) is available and recommended by F-Droid. As I said in another thread:

I really don’t understand why F-Droid is recommending this update when, in my experience it just doesn’t work when it comes to searching for apps, but you might want to tell F-droid to ignore all updates and stick with version 3.2.9 for the foreseeable future. If you have F-Droid set to automatically install updates, then you may want to do this pretty soon :slight_smile:

At the moment, /e/'s Apps store is still offering v3.2.9, and I hope they don’t plan to change to the new version.


I have the version 4.02, and it works well for me.

Yes. but it won’t get geo-restricted apps.If you don’t need them you’re OK. I’ll change the subject of this thread.

what are “geo-restricted” apps?

Apps that are only availabe to users in a specific country, e.g. a lot of banking apps. In my case it was a UK golf app, and the UK NHS COvis Tracking app

Check the spoof manager in the menu. I’m in Germany and I can see the NHS App, because my language is set to English UK.
Is this what you are looking for?

Could be. I’ll check tomorrow. Thanks

I have English (United Kingdom) ticked there, but it’s still not in the search results. It was visible i the search suggestions, but it juts disappeared (maybe because I’ve been making a nuisance of myself in the official support Telegram channel)

Could you please provide us with the app’s full names (i.e., so some could check from their countries using different languages ?

Apps I could not find include

  • UK Banking app
  • uk.nhs.covid19.production UK NHS Covid Tracking app
  • golf.playmore.caddy - UK Golf app, to book start times at the golf course where I play

I couldn’t get your apps by search, either :frowning:
Tried US English, meta (!?), French, Irish, …

But I can confirm that the banking app (didn’t try others, but should give the same result) can be downloaded by AS4 from a Play-Store link, using /e/ Browser :slight_smile:
I also succeeded updating one of my app, not found by search.

Thanks for trying. From what I’ve seen in the Telegram channel (where I was asked to leave because ‘negativity’ :slight_smile: ) I didn’t expect it to work, but worth a try.

I will be interested to see whether, once you’ve installed via a browser link to Play Store, AS will pick up future updates. I will go that way shortly.

First I’m going to try a workaround where you use a VPN to do the anonymous login from a specified locale. I’m only dojng that because I’m curious: I don’t think it would be a feasible workaround for most /e/ users.

Thanks again

I found a small workaround for the bad search (which may be obvious for some, and it won’t work for all apps).

Lately I also got the update to Aurora Store 4 and had to install an app that’s solely available via Google Play. I just couldn’t find it in the Aurora Store. There are different variants of this app which were shown in the results, but the one I wanted wasn’t showing (it’s a money transfer app and every bank has an own variant). I even checked the ID of the app on my other phone and typed this into the search, but no dice. A lot of variants where shown, just not the one I was looking for. And mind you, I tiped the full name of the variant.

So I went to the website of the developer, searched for the store link (The *Get it now on Google Play" style button) which brought me to the Google Play page of the app.
I then opened it in the system app via the browser menu (using Firefox). I selected Aurora Store as app and found myself on the page for the desired app in the Aurora Store and was able to install.

A second App I needed was found directly and installed just fine, so sometimes it’s just working as desired.

Yes, this is an intentional privacy feature, not a bug, in Aurora Store v4. See here for their explanation:

Due to popular demand, the developers implemented a way, disabled by default, to reduce anonymity and restore the old functionality of being able to get geo-restricted apps:


Anybody reading along here, please mind the reference to the other topic in the opening post and see Aurora Store, geo-restricted apps, and anonymous logins, too.