Aurora store stopped working after latest e/OS update May 9 2023

Today the Aurora store app stopped working after I updated E/OS.
Thank you very much for your help


You should clear the app cache. If this is not enough also the entire app memory. Aurora store does connect and show a lot of apps, it has currently a problem searching a concrete app.

1 Like

Thank you very much irrlicht I tried cache but still same problem. How do I empty the entire app memory?
Is that the button left of empty cache?

I just updated some Apps with it successfully.
Did you try again in the meantime?

Aurora Store on /e/OS 1.10-s-20230413279105-dev-FP3 ([HOWTO] Give complete /e/OS version info easily for support, answers, comparison etc).

Yep I emptied the cache but do not know how to empty entire app memory. Only the cache seems not enough.


Yes, the other one. You probably must then renew your app settings, that will all be deleted as if the app was installed freshly.

1 Like

Just did that. Installed aurora anew. trying to login using anonymus but still same error.
Another suggestion perhaps?

I deleted the whole app. Allowed all access and reinstalled the app again but that also does not work.

I guess that an app which installs other apps (this means: files) should get this permission of accessing all files. Could get complicated otherwise.

:sweat_smile: :upside_down_face:
Any other suggestions perhaps? Keep getting the same error message. Strange when yours works.
Would a rollback of the e/os be possible or advisable?

Could I use App lounge to update the apps I installed with aurora or would that mess up the system?

Any one else any suggestion? I am kinda stuck now.

I don’t think its an issue with eOS. I cannot search in Aurora for a while also in a much older eOS version.
Deleting cache and memory does not help. Also not reinstalling Aurora. However updates of already installed apps works. Seems to be an issue with current Aurora version
You can use App Lounge for searching for apps… I have both App stores (and F-Droid) installed

1 Like

I have checked that once on my older phone (with /e/os on board) but it was with F-droid. When I have installed something with help of F-droid it was also visible on App Launch and I believe that for updates it was also somehow synchronized.

Regarding not being able to search apps in the Aurora, there is a workaround for it. When you go to OS settings → apps → Aurora → one setting is regarding the website links to be opened automatically with this app. I’ve put there and send to myself on any messenger app the ready links from the computer. Than after clicking on the links Aurora finds the required apps rapidly :wink:

1 Like

Tip of the year:

Why even install any app that requires the use of microg that also stores some of the data? What yoy can do is simple create a shortcut for the browser webpage from apkpure that has thr same exact apps and just keep downloading the apps from there without any microg or any other data sharing eith microg

1 Like

You are right
“Deleting cache and memory does not help. Also not reinstalling Aurora”
For no reason it started working again last night. The strange thing is it asked me to install “google pay services” which I declined. I hope that is right?

Thank you very much for explaining. It was not that I could not search for app. The whole app did not start at all. For no reason it suddenly start working last night. Asked me even to install google play services which I declined. Hope I did right.

Thank you very much. Do you mean Aurora still is not safe?

I am not sure how much safe it is, however you can use apk download of the app website. For example Signal messenger downloaded from there when having no Google Play or microG cannot create a copy of messages, but the rest works perfectly fine. Plus app receives updates from itself OTA :wink: But it still depends on what apps do you need, as not all apps can be downloaded like that :thinking:

1 Like

When it is automatically updating that is a huge plus. I always forget to update cause I don’t use wifi. Maybe you read my comment. Aurora started working again out of the blue.I don’t know either how safe it is to directly download the apk from the website. Should not be a problem. Maybe other wizzkidz on this forum know?
I will save your advise in case it goes wrong again, the I have a backup plan.

I’ve read your message. My assumption is that it could be the same as happens once in a while with NewPipe app. When original YouTube makes some big change in original code and few hours or days are needed to update NewPipe adequately. As Aurora has similar type of relationship with Google Play I assume that it might be related to some update in the main store.
Does anyone else had similar issue and could advise?

It think you are right, that sounds logical ;-).
Thank you very much for helping out. :pray:
Wishing you a wonderful day.

1 Like

From their Telegram channel:
Please read carefully :wink:
Download URL is:

Updating installed apps still work flawlessly, at least on my devices.