Autofocus not working anymore on defaut camera app

Hi all,
I have a samsung galaxy s7 and since the last update, the autofocus is not working anymore.

To be more precise, when I click on the screen to do the autofocus it works, but when I take the picture it’s all blurry.

Before the last update it was working well.

To solve my problem, I installed footej that works fine.
However opencamera is still making blurry pictures …

2 weeks ago, I bought a Fairphone 3 preinstalled with /e/OS. I have problems with the autofocus, too:

I you tab the screen, you see the camera optic trying different focal distances. The preview changes from blurry to sharp and back to blurry. It is very annoying since I see, there is a sharp optical setting possible. The camera app just does not use it.

Setting the focus-mode to “manual”, I can adjust the settings to get a sharp picture. So I guess, it is not a hardware problem.

A workaround, I discovered: If I disable “Use Camera2 API” in the settings, the auto-focus works just as expected: Tap the screen -> camera searches for correct focal distance -> good focal distance is found and set -> I get a nice, sharp picture.

1 Like

With my FP3 the same problem except that disabling “Use Camera2 API” does not solve it.
Did somebody solve this problem?

A really good example of what it does with my phone …

I also have this issue on my Xperia Z5 Compact. When I press somewhere on the screen the AF square always become red (AF failed?). Only once in all my tries has it been green. Manual focus works, but I rather have AF.

I tried to disable Camera2 API without success.

Focus do not work with OpenCamera with my FP3 and has never worked. This is just unbelievable.
Focus works with BetterCamera and Camera at least.
I hope such bugs will be corrected before a production version of /e is released!


I didn’t install OpenCamera on the stock Android before switching to /e/, so cannot tell about the app’s quality on my Xperia.

I checked and there a few tickets related to autofocus, but I think all are for Camera2 API.

Perhaps, in my case, it is related to missing proprietary firmware blobs. I tried some other app, but result is unfortunately the same.

It’s a shame it doesn’t work for you if you bought your phone with /e/ (even though it is labelled as ‘beta’), at least in my case I installed the software by myself.

1 Like

Hopefully this is being fixed in the near future or replaced by another app. I can try to manully focus on the Fairphone 3+ but the results aren’t always 100% sharp.