Automatic Dark Mode doesn't work

Since the update from 0.18 R to 0.21 R the automatic switching (“turns on from sunset to sunrise”) of the Dark Theme does not work at all. I always have to switch it manually, nothing happens automatically.
Is this a known problem and is there a solution?

1 Like

I need to watch it more, but it seems like Dark Theme and Night Light are working the wrong way around: In the evening they both turn off and in the morning they turn on. :crazy_face:

I had this issue on 0.18, and it seems to be fixed on 0.21 (Redmi Note 7 Lavender 0.21 R)

This morning and this evening the automatic mode worked normally. Very strange. I continue to monitor.

This morning the automatic switching did not work again. Apparently, the device “thinks” that it is still night, but the sunrise was already over an hour ago.

This is definitely buggy.

Occurs on mine too. I just disabled the automatic dark mode.
However, automatic night light does work now.

I see that an issue (for which I participated) is opened there:

1 Like

I am honestly amazed that this problem has existed for so long.

The Dark theme “turns in from sunset to sunrise” setting still does not work reliably. (0.22 R, Oneplus 5 ‘cheeseburger’)

It is really very strange, now it seems to work again. At least yesterday and today dark theme and night light were switched automatically.

Just now, around 9 o’clock in the morning, the dark theme turned on automatically. It is broad daylight!

Not sure about what I am going to write, but I am under the impression that automatic dark mode rely on gelocation to work.
As long as geolocation is turned on, automatic dark mode is enabled every night without fail, but if I disable geolocation, I know it will stop working after a couple of days.

Is that what you mean?

Both functions, dark theme and night light work completely chaotic. This afternoon they switched to night mode. Now that it’s been dark for a few hours (21:37) both are off.
Completely chaotic and not usable.

I am now sure that it is due to incorrect location.
Just now the night mode has switched on again, although it is 8 o’clock in the morning. I then started magic earth and my location is 7000 km away from my actual location.

Obviously the location is not working!

I’m having the same or at least a very similar issue on my GS290 (/e/ 1.2). Night mode isn’t working to any real life night&day scheme. Location, however, works fine. Just checked: 11am, bright light outside, MagicEarth places me at home, yet the phone insists on helping my eyes with night mode.
Location services in microG are both activated.
Time zone taken from (German) network provider.
I don’t write this to just add my 5c, but to push the issue and offer my help, too, if Devs need more info to solve the prob.

1 Like

I don’t have the problems with location anymore since I switched from the location module ‘mozilla location service’ to Deja Vu.

But the night mode still works unreliably.