Axon 7 2017G / B11 / Bootloader issue

Hey everyone !

Sorry in advance for the n00b question, but I’m stuck in the process of unlocking the bootloader, in order to install the /e/ OS. Feeling a bit helpless after countless hours of reading forum posts, tutorials and what not, through all the available topics on XDA and elsewhere, regarding LineageOS installation guides and other alternative OS. Still stuck to square one.

  • Unlock dev options → OK

  • Unlock OEM / USB debugging → OK

  • adb devices → OK

  • adb reboot bootloader → OK

  • fastboot oem unlock [or : fastboot oem unlock-go] → FAILED (remote: unknown command)

  • Tried 3 different cables, all of them are able to send data onto the SD card

AXON 7 2017G / B11 / Android stock 6.0.1 / kernel 3.18.20
Linux Mint / adb and fastboot installed from stock repositories

Any charitable soul around for a bit of help ?

Thanks in advance, guys… :slight_smile:

Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone

I can’t remember that far back, to be honest, when i unlocked my A2017U.
I know you’ve probably checked all over but just in case…
Here’s a thread from 2016 but the OP mentions only up to B10. Didn’t check the rest of the thread though.

[GUIDE] [A2017G] Install TWRP, Unlock BL, Flash Custom ROM

Other articles like this one, Unlock Bootloader Install TWRP recovery and Root Zte Axon 7 A2017, look pretty much similar to what you’ve tried.

I think with Marshmallow, the first link is the one to use (according to another thread I read). Requires the use of axon7tool.

Hey Marc !

Thanks a lot for your answer.

Yeah, I’m not too much into being up to date, when it comes to phones. I like what does work well, and this very phone has always been way enough for the little I have use of it. The first one I had was running a LineageOS unofficial rom, and for sure, I didn’t struggle that much with that older version of it…

I’m running Linux, on my computer. Might as well just install W10 somehow, and follow that guide.

Thanks again for your time. I’ll keep the thread up to date for other Axon7 users in the same situation.