BankID app not working

Hi, in Norway, we have blundered into making BankID (a commercial product which is a collaboration between several banks, I believe) the standard for authentication yourself to public authorities.

BankID comes in several flavors, but today it’s either ID+password+2FA from a dongle or “BankID på mobil”, which is a SIM card application that can run on pretty much any phone in existence.

This latter flavor is what everyone wants, but it is a bit unreliable, and uses SMS as its transport, so it’s being decommissioned. The New Thing is the BankID app (

Looking at the app ID, it appears to be made by the Vipps people (a payment app). Vipps works nicely on v1.0 (or previous versions with magisk), but BankID does not. It doesn’t even start up, just redirects you to a web site explaining why rooted phones are bad.

Has anyone else tried to get this to work on /e/os? Any tips on where to go? I have a FairPhone 4 with v1.0. I have magisk installed, but since upgrading to 1.0 I haven’t re-patched by boot image, so currently magisk is just sitting there. I did try with magisk and MagiskHide and whatnot before the 1.0 upgrade, which didn’t work.

Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone

1 Like

Hi @hgb which Android version do you have Q (10) or R (11)?


(Also, I need to make sure the reply is at least 20 characters long)

Is it the stable build?

On my FP3 with 1.0r-dev it works. Can you check in the microg-setting what the respons is from ‘SaftyNet-Certificate test’? My device is german I don’t know the exact translation.

Hmm, I can’t find a certificate test. When I go to Settings->System->microG->SafetyNet->“Test SafetyNet attestation”, it says it passed all tests. I didn’t really manage to run through the ReCAPTCHA.

I’m on the stable build, so of course, could consider jumping to dev.

I had an exchange the other day in this post. I might be the same reason.

Hmm, could be. Every indication on my phone is that SafetyNet passes, but the blasted BankID app somehow detects problems anyway.

Did you install it from App Lounge? Or was it on Apps? Or even Aurora? :smiley: Maybe try reinstalling, from App Lounge. Bootloader is not unlocked right? :wink:

Bootloader is unlocked. I have Magisk installed, and I was under the impression I needed to keep it unlocked. Plus, I can’t lock it again without deleting data…

But I thought Magisk etc could hide that status from the app.

Can try to install from App Lounge.

App lounge didn’t help, but of course, with v1.0 improvements, I could always dump Magisk. I would still like to be able to lock it without losing all data, though…

I don’t use magisk nor I know how it works. Yeah losing data Is bad, maybe look in to the backup function in the settings (seedvault).

The app gets initialized and comfirmed by my bank. However the init phase never completes. The animation( rotating blue) never ends even after my bank confirms init is done by sending mail and sms.

Tried with VPN and Advanced Privacy switched off. Made several attempts, all confirmed by my bank but it never worked.
In my view this is a comm/network related thing. BankID tries to connect to my phone but for unknown reason, it never gets past some obscure barrier.
The bankid on mobile does work by similar concept though.
Running e/OS 1.2 Gigaset 290.

Yes, this seems to be the same issue that I’m facing, same thing with Vipps.

Is it the same issue as here, that the app is not web-browser agnostic?