Basic terminal help to install twrp please!

I have previously stumbled through and successfully installed the e OS on a OnePlus One. However, I bought a 5 but I’m having some trouble. I think it is just a simple command issue. I have pretty much no experience in the terminal, so I just blindly enter in whatever is in the How To guide. So far I have ADB running and I guess Fastboot as well. The phone is in FastBoot Mode, and the device state is “unlocked”. I am stuck on the step of typing in fastboot flash recovery twrp.img

I moved twrp-3.4.0-0-cheeseburger_dumpling.img into the Platform Tools folder, and renamed it twrp.img

In the terminal I type in: desktop/platform-tools/fastboot flash recovery twrp.img

I get the error: cannot load ‘twrp.img’: No such file or directory

I have tried leaving twrp.img on the desktop, and also leaving it with the original long name and changing the command accordingly.

I suspect I’m missing something goofy with the command, or is Fastboot not “running” on my Mac? I have hunted around but this is such a simple part of the process all the guides just run through it.

Losing hope after wandering around for an hour… any suggestions? I love the OS and use it as my daily driver on my One, but this install on the 5 has been a bit demoralizing.

Thanks in advance!

Here’s a really good and short 1 page introduction to the basics …

Since your steps sound good to me as a non-Mac user at a first glance, can you provide a screenshot of your terminal session where you get this error message?

Screenshot 2020-12-12 at 11.42.34

It seems as though I just need to do something to point the flash recovery to the right file.

Hi @Franko, I’m not a mac user either but I would guess it’s similar to ubuntu and it looks like you may not have terminal in the platform tools folder to issue the fastboot command.

Can you right click a folder to get options menu where it offers “open in terminal” or something similar?

Another way is to navigate to the folder whilst in terminal: cd

1 Like

Try cd /desktop/platform-tools/ before running the fastboot command, or you will have to point to the platform-tools folder for fastboot as well as for the twrp.img (/desktop/platform-tools/fastboot flash recovery /desktop/platform-tools/twrp.img).

So, I right clicked on the Platform Tools folder to open another terminal window, to keep things simple. I tried the flash recovery command, but received the error “command not found”. I included a shot of the folder just to show that fastboot is in it. Command not found???

If you want to use the slash with the command, it has to be with a point (this results in forcing the command line to look for the fastboot command in the current directory) … ./fastboot :wink:

/fastboot here is given like a file or directory in the root folder ("/") … and this file or directory doesn’t exist, as the error message says.

And you could still try /desktop/platform-tools/fastboot flash recovery /desktop/platform-tools/twrp.img.

1 Like

Scroll down on this info and look at Method 1 :

To get started, ensure that terminal and fastboot recognise your device by issuing this command

fastboot devices

If your device is recognised terminal output should show your phone serial number or something similar.

If not recognised , no output.

This is what it looks like in linux

Nice. The point and slash in front let it go ahead. Thank you very much. Moved on to the sideload section now, and I seem to have gotten into a similar issue (I was so close…)

I start the ADB Sideloader on the phone.

I type in ./adb sideload (I put the .zip into the platform-tools folder)

On the phone, I receive the error: No such file or directory, E1001: Failed to update system image

Do I need to reboot the phone before starting the sideload?

Screenshot 2020-12-12 at 16.13.34

Tried stopping and starting the server too, just 'cuz.

./adb sideload ./

… assuming you have the ZIP file in the platform-tools directory.

(The terminal has to find the adb command to execute it. Since the terminal somehow doesn’t look for it in the current folder, ./ forces the terminal to do that.
sideload is a parameter given to the adb command to tell it what to do, so the terminal doesn’t need to look for that, so no changes necessary here.
The file to sideload has to be found by the terminal again … same problem as with adb and fastboot, so ./ forces the terminal to look in the current directory for it.
Your second try would have worked, I think, if you would have given /desktop/platform-tools/ instead of /desktop/.)

Screenshot 2020-12-12 at 16.30.13

Damn this is getting annoying!

I tried adding the ./ to find the .zip file, and tried added the folder path as well. Odd how I received two different errors after trying the same command.

Still getting the same failure error on the phone.

Where did you put the file?
What does the ls command show where you are now (platform-tools).

I put/had/have the cheeseburger into the platform-tools folder.

Screenshot 2020-12-12 at 16.41.04

Looking good.
Internet says macOS has sudo (like Linux) … If you are an administrative user/ superuser (says the internet for macOS), you can try sudo (to execute any command with administrative privileges), so sudo ./adb etc. or sudo adb etc. in this case … sudo will prompt you for your user password.

If this doesn’t work, I’m out of ideas for now, unfortunately.

Does ./adb devices or sudo ./adb devices or sudo adb devices find your phone? (This command would display an ID of your phone if successful, showing that the connection to the phone is there and that ADB would work in principle.)
If not, I guess this would have to be troubleshooted by someone with macOS expertise.

Hi again,
I checked and the phone is still listed as connected. I used the sudo command and still came up with the same error on the phone.

Will I bugger it up if I try rebooting? I remember rebooting a bunch of times with the OP One when I previously put Ubuntu Touch on it. Very crude but my technique quickly degrading into just trying to ram it down it’s throat over and over. Lost the patience to logically troubleshoot and eliminate issues. Kinda turning down that road again now!

But seriously, thanks a lot for your help. I bet this is just a tiny hiccup, but it sure has me stumped! Taking a kitkat break for now.

Oh man.

I rebooted the phone, back into recovery mode again. Verified it was talking to the Mac. Entered: sudo ./adb sideload ./

Boom, installation starts. All done, phone is up and running.

Thanks everyone for your help, the community is great. I tell everyone I can about the It takes awhile but after people watch certain movies and documentaries, they realize how important this project is.

Off to customize the settings!

1 Like

Hello everybody,
i just receive my oneplus 5 and need many helps to install /e/, is it the good place?
I’m french and then not a good english user.
I can’t create the new topic “help for beginner oneplus 5”
All help is welcome, many thanks…

When you join the French group at you should be able to start a new topic in the “/e/ Support Utilisateurs” category at

1 Like