Battery does NOT charge anymore

I am having problems charging the battery in my Fairphone 3.
Until recently, the phone would either go into “charging” or "fast charging.
I don’t understand when one or the other takes place and if I can influence that.
But now the battery is not charging at all.
I already bought a new battery, thinking that might be where the problem is. But that is not the solution.
Now I am left with an unusable phone.
Does anyone have a suggestion?

I tried different chargers including the original battery charger from Fairphone.

Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone

Maybe the USB-C port is not working anymore. It is possible to replacethe bottom module containing a new USB-C charging port:

but I generally speaking suggest to contact customer support at Fairpohone

1 Like

I had a similar problem with one of my devices. It was fixed by cleaning the USB-C port.
Worth a try before sending it off for repair

1 Like

One more option apart from the USB-C port and the charger is the charging cable.
Have you tried other cables since the problem started?

Another question: Does the LED stay all dark whatever you try?

This has not crossed my mind but I agree this might be the case. It happened a lot with my husband’s USB micro B.

This method does is low tech and does not require compressed air:

1 Like

Disgusting, but also very helpful :smile_cat:

Hi, I’ve already done that. The ‘problem’ is their response time: 5-7 business days.

The device simply indicates charging.
The state of charge just does not increase.
Fully charged in 4 days
But nothing changes

Thank you for this. Unfortunately it doesn’t fix the problem.

Hi, I tried all the calbles and chargers I have. All with the same outcome.