Battery drain after multimedia storage usage (to check generically)

HI e Community,

I remarked last days that a strong power drain is done from multimedia stockage sw unit after I’ve connected my device per cable on computer.
Device should be charged after one day usage.
What’s not happened if i upload my files per Bluetooth.

I was not sure about it on the 1.09 and 1.10 because it happened rarely (such exchanges with pc were rare too). But Today is sure, every time happens this behavior after pc exchange through usb.

Samsung galaxy s10+ eOS 1.11s
Pc with linux mint 20.3

The point that i create this topic separately is because I think that’s a software issue which need to be checked on the os side.
That after an exchange with the pc, even if the device is (from user mind) correctly unmounted there is still an activity side of device which drain the power.
Don’t know if it’s a service , a tool, a daemon, or on the blob.
The point I think is that the OS should be aware of it, and depends on which device it is should react to avoid this situation.

I’m ready to give feedback for analyze any activities, if someone give me some info on how to do it.

this never happened definitively by the version under the 1.8.1 and equal, or related to the R version…

Would be happy by having any feedback.


Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone

1 Like

Hi. Just read the teams found the bug and a solution in v. 1.12:


thx for the link.
in this side I found an other link where the description seems to fit with my observations:

At the end of (your link)
Would report that the problem comes from a patch and will be reverted.

And then? what will be the next step?
The patch was implemented to fix a specific issue, then the former one issue that the patch has fixed will be there again.
Ideally would be to fix the new issue.
If not, then I hope that the eOS dev team, would informs what does it means if the patch is inverted.
Which issue will come back…

I have this issue also. Read all the related gitlab links but unable to sign up there to post.
It seemed issue was resolved for some people on /e/ os 1.12 but I am on this version and still have the issue.
Removed account and going to full charge now.
Will report back

removed and re-added murena account, no change.

Disabled media storage using adb. Issue stopped but if course now can’t access pictures. Music or anything

i’m not sure to understand why the media storage use the adb…

And how it is with media storage reinsertion? or change with an other one?

I believe it was shown in other posts here that the account manager app for is accessing Media storage too much and draining the battery.
I disabled Media storage using the Android Debug Bridge (connecting my computer and disabling the app).
Now that Media storage is blocked, the battery issue is gone.
Unfortunately, I cannot use photos, music, maps, etc. because they all need Media storage to function.

@jobal Are you still having the issue? I haven’t been able to resolve.

Hi, would be possible to have where do you have the info that is use via adb?I can’t see such kind of parameter by me.
If I gave a look on the murena account i see in settings the possibility of “verbose journalisation” by me is not active, and maybe it could suck some ressources.

Maybe give some screenshot to be sure on where we could see how it is by us… just for comparing…

Well, as you noticed, media storage is an essential part and should not be disabled.
For testing purposes did you disable the syncing of “Pictures and videos”? If not try that on the next battery cycle. If I am not mistaken that may trigger what appears to be high media storage usage.
It encompasses images, videos, music, and even Documents.

Strange is on my side, i have an app for smart bluetooth device, that i don’t use since 3 month.
Had tried to force to stop and it still there and use regularly between 20% 25% and seems never to be ranged to the unused deactivated one (or I don’t remember how it is cold).

And the WAKELOCK service take around 20% too don’t know why…

could you maybe explain why the media storage use adb (regarding what he told).
I know that with usb connection the mtp is used.
Per BL the own bl interface. but why adb? and how we may parameter to use/unuse it? or get the info or check what he told.

He didn’t say Media Storage uses adb. The ROM does not allow to disable most system apps. So he hooked up the phone to a PC and used adb commands to disable it.

1 Like

arg! logic, my english not so good, but was really tired last days.
yeah thanks.

@elhdjrmlifq6 could you tell more about the battery report in the settings which parts use the ressources mostly?
On my side as I told before I have the issue which moves elsewhere (not from media storage anymore),where the matrix powerwatch app is unstoppable and never been parked by the unused apps, wakelock seems to be a problem too and OS android itself…

No, it solved with version 1.12.3, and without doing nothing.

Here I wrote 100-0 in 2 days:

but now, after a few charge operation, I can said that battery goes down from 90 to 10 percent in 2 days with the same usage.

Darn! not solved for me :frowning:
Thanks for the reply

haha, right. That was the nuclear option and it worked to be sure. Not sure if the phone is more useless without media or without being able to use it for >an hour.
The only thing I have synced is contacts.
I believe I read above or in gitlab that removing the account also stops the issue but then I dont have contacts just numbers

Media Storage will be the majority by far.
Currently: 32%/ used for 10:22 hours
Next highest is VPN @18%

By older version I had the issue with my computer which have linux mint where I exchange some datas per usb.
That happened afterwards until I restart the phone, and then it stopped to drain.
I tried it with version 1.12 one time, and didn’t happened.
What’s about you if you restart the phone, it still drain the battery?

do you have an sd card?
If yes what’s happened if you remove it?
Or change it.