Best way to flash /e/ on brand new Pixel 5

According to this, i should be in the perfect condition (Android 13 stock) to install e.os S based on 13…

These letters and numbers are so irritating … you are right that you are trying to /e/OS on top of a “foundation” Stock at the same Android version. Today, for you, that is Android 12 (=S)

Android OS 10 11 12 13
/e/OS build q r s t
LineageOS 17 18 19 20
1 Like

Thanks for reply
Damned, i misread versions…so i can’t use e.os as pixel phone is yet under 13…?
Nevertheless i don’t understand why it’s stuck on “reboot on bootloader”…:thinking:

I think I see on your phone image “Device state locked” ?

We don 't know how Easy Installer reached this point, whether it started the unlock … ??

It may be a learning experience to cross reference your log

  • Linux: ~/snap/easy-installer/common
  • Windows: %LOCALAPPDATA%\easy-installer

with the manual instructions.

1 Like

apparently your bootloader is locked.
try adb reboot bootloader
if that doesn’t work try re-unlocking steps.

1 Like

Thanks @aibd and @Tech-e1 for your replies
Yes it seems locked as i followed all steps : developper mode, USB transfer, ticking “debugging USB” and “OEM unlock”
So far i think it has to see with android version so i looked around and found this : more especially this tutorial to downgrade to android 12 :

This command is working but ends at same point than previously…even if i have ticked “OEM unlock”, “Device state” sticks to “locked”… :confused:

It’s weird : i do have in developer options the option “OEM unlock” but once rebooted in bootloader device is locked so If @piero here is the same as on xda any insights would be appreciated…:grin:
I’m thinking to downgrade to android 12 using sideload, condidering i have a locked bootloader, but i’m not sure i’ll be able to then install e/os/ as it needs a unlocked bootloader…

Edit 1:
Following these steps : prompt says
This leaded me to update USB drivers…now it’s unlock…
Should i downgrade before installing e/OS/…? I suppose i do

Edit 2:
Tried flashing factory image with fastboot, but it failed
and rebooted to previous android 13 wiped…
Trying using now…which seems ok




Navigate this article:

choose method 2 : fastboot (at the end of the article)


Gogol Stock firmware Downloads :


Then :

/e/OS Downloads :

1 Like

Hello, thanks @piero (again because you helped me years ago installing e on my S7 ^^)
Finally as fastboot wasn’t working i tried downgrade with which worked (guess i didn’t choose right image…) and now e is installing with easy installer…:crossed_fingers:

I went trought all steps of easy installer but i now have :
Can’t find valid operating system.
The device will not start.
I think i’m good to follow your steps @piero or at least reflash e./OS/ because last working OS was android 12 stock so i guess that’s easy install of e./OS/ that corrupted it…

Followed steps directly reinstalling e.os with the classic tutorial:
instead of this
i got this :

Nevertheless the phone is back working with e-1.11-s-20230510288098-stable-redfin, don’t know what went wrong with easy installer…

Is it possible to get rid of this ?

Thanks @piero

Well done. Your image from the update screen has all the features you want to see

Data wipe complete
Installing update
Step 1/2
Step 2/2

Your second image is of the “yellow” or “orange state warning”. Verified boot – boot flow

It is connected with your unlocked bootloader.

Unusually for /e/OS, the install instructions for your device do cover

Locking the bootloader

… you might read further if want this …

Hello, thanks, it’s yellow
I followed all steps included relock bootloader…

Previously i had a pixel 3a on which i didn’t relocked and got everytime orange message, may i relock it…?
I can live with this message

So you went to the trouble of locking the bootloader and you still get a “Yellow warning”

Very tolerant of you :slight_smile:

Not for a Pixel 3a, see also [LIST] Devices where bootloader can be relocked.

Oh yes, in between i even got a red message (see post) with phone refusing to boot (i thought i bricked it :sweat_smile:), so a yellow message it’s ok…!
Do i have to stick with the yellow message…? Because to my opinion i did everything to not have, even if it doesn’t really bother me, is it a sign of something wrong on my phone/installation…?
Thanks in advance

Did you follow the link to ?

Google, having given us AOSP, decide we need reminding that it is still not the same as Google Android.

The flow chart I linked earlier demonstrates what sets off the warning, as far as I am aware it is “designed in”, so nothing to do with your install.

One can find ways to eliminate these messages on a Mediatek device, but in general I think they are “permanent”. It would be good to hear different :slight_smile:

Android was open source when gogol toke control over the projet,
Let it open source was mandatory i think…
Also free contributions are welcome.

1 Like

Hi there, I just bought a refurbished Pixel 5 with /e/ OS from the Murena store, and it also shows the yellow warning on start-up. Apparently we can’t get rid of it. To be honest, I don’t really mind. Otherwise the phone works fine!

This topic was automatically closed after 180 days. New replies are no longer allowed.