Birthdays are synced twice in built-in calendar

I exported/imported Google contacts to Murena account. I turned off all syncronization for the accounts and Kontakte ( og) (why are they two accounts to sync contacts anyway?). Furthermore I deleted “Storage and cache” in Contacts, Contacts Storage, Calendar and Calendar Storage.

Now if I turn on Settings > Accounts > > Account sync > Calendar. When I open Calendar now, all birthdays are shown twice.

I don’t know what to do anymore, Any help? It’s frustrating…

EDIT I: If that matters, I am using Sony Xperia Z3 Compact and latest Android Q (

EDIT II: I deleted/imported my contacts to Murena account one more time. Now they a shown 3 times, even after I deleted all contacts again. What could that be? Cache?

1 Like

I have the same issue: birthday of contacts are showing up twice in the calendar. I have /e/OS 1.0-20220526188859 on a Samsung S7

This process ended up having all birthdays 6 times in my calendar. Every time I dropped all contacts and added them again I got one more birthday.

After I had the same issue with Simple Calendar Pro I finally found the problem: In my case it’s not /e/OS, the calendar or calendar storage… it’s the ecloud! Login to > go to calendar > drop birthdays > add them again.

I hope this helps.

So it’s a bug with ecloud? @Manoj is going to tell us to post an issue in Gitlab

Issue reported: Calendar app: birthdays are synced multiple times (#5744) · Issues · e / Backlog · GitLab

1 Like

Where do you see ‘drop birthdays’ please?

I deleted the entire “Contact birthdays” birthdays, then “Settings & Import” and check “Enable birthday calendar”.

1 Like

Gitlab issue #5744 will be closed.