Black screen after screen replacement (Xiaomi MI A1 / e .17 Q)

I had the screen of a Xiaomi MI A1 replaced. I think the replacement was done while the phone was ON. When I took it from service, it worked, but after the first reboot, the screen was black. The powerOn button worked, the 3 touch button worked, because I could hear the sounds/vibrations and I could see the backlight. It had /e/pie installed.

What works:

The guy from service flashed the official ROM (keeping the boot unlocked). The system was working.

recovery-3.2.1-2-oreo.img works, but can’t adb sideload the new zip files (with payload.bin).

I’ve flashed an Evolution build ([ROM][11][tissot][OFFICIAL] Evolution X [08/05/2021] | XDA Forums) and a the latest crdroid build ( - Download crDroid for Mi A1 (tissot)). They work. I’ve used the following steps:

payload-dumper-go payload.bin
fastboot erase userdata
fastboot -w
fastboot erase system
fastboot flash boot extracted_*/boot.img
fastboot flash system extracted_*/system.img

What doesn’t work:

twrp-3.3.0-2-tissot.img. I get the same behavior as with /e/ (black screen while the backlight seems to function). I have to boot to recovery with the oreo image (mentioned above) and run adb sideload I can reboot to recovery with 3.3.0, but something strange happens. I get errors usb 3-1: device descriptor read/8, error -32. flashed the way I did with crdroid/evolution. Black screen. Backlight on, those 3 touch buttons work. After blindly touching the screen I can hear the dial pad sounds (emergency call). On timeout, I hear the lock sound and I see the backlight going off. (a lineage image with microg from doesn’t work, neither (LineageOS without microg). Same behavior (black screen)., recovery-e-0.14-q-2021012698290-dev-tissot.img - same behavior.

ROM from PixelExperience P11+ doesn’t work (black screen), but P11 does work. According to blog, P11+ has face recognition :slight_smile: (

Any advice on how to put /e/ back on Xiaomi MI A1?

Just taking your report from the top, do we know the service guy definitely flashed the exact correct ROM, and what version of MIUI and Android he left you with?

Your device has 2 slots A/B. Then when flashing both the BOOT and SYSTEM partitions, you must specify the slot you want to flash them into. Both 2 partitions must be flashed in the same slot, and that slot must be left as active before rebooting the system.
For example:

fastboot flash boot_a BOOT.IMG
fastboot flash system_a SYSTEM.IMG

And finally you reboot:
fastboot reboot

@aibd, I didn’t touch that ROM much :slight_smile: I remember it had the AndroidOne logo during boot and that I saw Android 9 in Settings.

@LEPT I’ve tried every Kung-Fu style :slight_smile:

fastboot set_active a
fastboot flash...


fastboot flash XXXX_a
fastboot flash XXXX_b

I’ve used even an old image (Oreo, I think) that has an script, flashing both slots.

However, I can’t flash an “official” ROM successfully. Either it hangs on boot (for at least 5 minutes, with the animated AndroidOne logo), either it reboots (Oreo). Maybe using only fastboot is not enough, but I don’t have a windows system.

I don’t exclude a hardware issue with the new screen or other components. And this becomes more likely as I try more things.

Are you aware of

that has worked fine for me on Debian Buster.

I didn’t know. Thanks, @aibd . I’ll give it a try.
I found another tool - Xiaomi ADB / Fastboot Simple Tool – Xiaomi Tools

The problem mentioned above it was caused by my cleanup of the userdata partition with:

fastboot erase userdata
fastboot -w

I’ve used an userdata image from Oreo to restore it:

fastboot flash userdata userdata.img

Now I have a working Oreo on slot A and E18 on slot B (where only the touchscreen and the backlight works). I think it has something to do with the cheap display replacement.

I have been watching this thread with interest because I had the same problem.
I also replaced the screen on my Tissot and afterwards could see the Fastboot splash screen so I know the screen does work, but nothing else. I can install /e/, and I can hear the beeps as I use the buttons but the screen is blank.

I gave up and just bought a different phone.

I had my screen replaced three times. It seems that the last one was done with a cheap LCD. I can barely see the screen in sunlight and it has blue-ish faded colors. Another service told me this (that it is a cheap LED screen) and that they could not find an IPS-LED screen from their distributor (or whatever was the original one).
So, if this is true, the E build for tissot doesn’t have the driver for this LCD. Until it will, I’ll put crdroid+magisk+microg on this phone (see how usable is), retry E builds from time to time. After using E for two years, I could not handle a gapps setup for more than one day.

Or could it be the OEM partition of the phone which does not have the correct driver? I did try to reflash the phone with a stock Xiaomi image as well, and that did not work either.

From what I understood, the ROM images are found in two formats: a tgz (with scripts) to be flashed with fastboot and a zip file for recovery (installed from TWRP). Last time I’ve used it locked the boot because I’ve missed the fastboot oem lock line. So, I tend to use the zip file (for recovery), but not from TWRP. I unpack the payload.bin with payload-dumper-go. Almost custom ROMs (/e/ included) have only boot and system images in that payload, and when I flash them I reformat the userdata partition. The official ROMs have way more partitions.
From my notes I see that I’ve successfully flashed an official ROM with:

mkdir o
bsdtar -C o -xf
payload-dumper-go o/payload.bin
fastboot set_active b
fastboot erase system
for i in aboot tz devcfg modem boot keymaster cmnlib cmnlib64 system lksecapp rpm sbl1 dsp
	fastboot flash $i extracted_*/$i.img
fastboot flash userdata oreo/tissot_images_V9.6.8.0.ODHMIFE_8.0/images/userdata.img

Without flashing userdata.img (from a random official image) - the last line - the phone will hang (sometimes reboot) in the animated AndroidOne boot screen.
I’ve reproduce it with the latest image ( from Mi A1 Global MIUI V10.0.24.0.PDHMIXM Update | Xiaomi Firmware Updater). I didn’t touch the userdata, because I have a working crDroid+microG on slot A and I think it will clean up my data).
If I flash /e/ (boot and system):

mkdir e
bsdtar -C e -xf
payload-dumper-go e/payload.bin
fastboot set_active b
fastboot erase system
fastboot flash boot extracted_*/boot.img
fastboot flash system extracted_*/system.img
fastboot reboot

The next screen I see (after reboot and the white one with a not-animated colored line in the middle) is a black one with the backlight on :slight_smile:

EDIT: Unfortunately, after this last try with /e/ on slot B, my working system from slot A didn’t boot. It hanged like AndroidOne, with an animated crDroid image. I erased the userdata partition and reinstalled all apps.

On devices with slots ‘a/b’, you must explicitly indicate the slot.
Not all IMGs you flash have 2 slots, but many of them do, so you should use the commands:
fastboot flash boot boot_b boot.img
instead of…
fastboot flash boot boot boot.img
…to flash the BOO.IMG in the BOOT partition of slot ‘b’

Hi, @jims3! I’m having the same problem you had: black screen with twrp and custom rom (in my case lineage) and screen ok with stock rom. Coud you fix it somehow?

Do you think we could copy something from stock rom images to the custom rom images (some driver?) that would fix this?

@diegodlh , I guess the kernel driver is an important factor, but even builds done by the same team differ (as I’ve said in this post about PixelExperience).
For me, the replacement was a pain, as the screen was barely readable in sunlight. Now it is broken again :slight_smile: and it isn’t worth replacing it with one of the same quality.

Thanks for your reply! I haven’t tested the screen in sunlight yet. I’ll do so ASAP to see whether I should return it, maybe. I think you missed the link to the post in PixelExperience?

It was in the description:
You will find P11 and P11+ there.

I’ve bought a new screen with the frame, the original , (Original M&Sen 5.5" For Xiaomi Mi A1 MiA1 LCD Screen Display+Touch Screen Digitizer Frame For Xiaomi 5X Mi 5X Mi5X LCD Display|touch screen digitizer|screen touchdisplay screen - AliExpress) and now I have a running E :slight_smile: with encryption.

1 Like