Boot stuck after "successfull" installation on S10+ (G975F/DS)

Hi there,

I’m experiencing a quite fatal issue on my samsung S10+ (SM-G975F/DS).
I successfully followed the instructions of this page

I had successfull feed back at every step, untill the very end : " Script succeeded result was [1.000000]" in recovery, after flashing /e/ os from ADB.

So, I restarted my phone, but it stay stuck at the “Samsung Galaxy S10+” boot splash (that come after he “ask” to press power button informing me that “the phone’s bootloader is unlocked and its software integrity can’t be verified…”), with a message in red : “This phone is not running Samsung’s official software…blabla security, updates and stuffs…” (I already had this message earlier, when rebooting (without trouble) from OEM unlocking steps.)

I can reboot to recovery or bootloader. Tried everything I could to make it work (wipe cache/Dalvik, wipe data…) but nothing worked.

Each time I boot I got the same samsung splash stuck.

I don’t have any idea that those informations are linked to my issue (I would think not), but I give all the few informations and understanding I have of the situation…

Thank you for answering me.

Well it really seems to have something to do with this red message warning, cause I just tried to flash lineageOSforMicroG and got the very same issue…

Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone

I’ve found out on the internet information about this message in red (most known as the yellow warning sign issue).
I red stuffs about the firmware version that may be important to succeed. So I spend a lot of time with a windows machine (not mine) and Odin trying to flash stock firmware -from here : [Download SM-G975F / Galaxy S10+ SM-G975F BOG in Samfw - Samsung firmware download] … After a lot of time and stress (hardbrick situation) I finally succeed (with the latest version : …HVJ5).
So I was back to the beginning with the Android OS I don’t want, but this time to it’s newer version (I didn’t take the time to check it on the first installation).

I followed once more the install instruction page, so now, i’m stuck to this same good old yellow sign issue…

This image shows the conditions for the Red and the Orange warning state Boot Flow  |  Android Open Source Project. I understand from other comments that the Orange warning state is rather striking on the Samsung S10.

Sadly /e/OS users are stuck with the 5 second Orange warning state.

I’m not only stuck for 5 second on the bootloader (and the sign is definitely yellow, whereas the red text -and the one just before- is speaking about unlocked bootloader secure danger…)

Also I found firmware updated linked to this yellow sign stuck issue (link found on XDA developper’s forum) : but didn’t get a successfull result trying to flash it (throught heimdall nor Odin…)

EDIT : well, checking again, maybe the sign is orange, but I’m sure… Anyway it DOESN’T dismiss after 10 second…

EDIT 2 : Shall I tried to flash this very newer firmware version :, and try reinstalling from beginning?

So I guess I picked an answer that fitted the colours, but not the situation which I do not understand.

I now think this was not a “successful” install ?

What make you think that the installation wasn’t successfull as it feeds back a successfull install? How may I see and check it?
And if so, what should I do to have a successfull install?

Thank you.

Thank you for confirming success – I guess I was trying to get a more certain idea of what has happened.

Is it possible for you to post an image of this yellow / orange problem, which you described as “stuck”.

No !
Curently You need a “GHVIx” Stock ROM where “V” is 2022 and “I” is september (or an older one) to be abble to install official e-1.6-x-2022xxxx

e-1.7 sould be compatible with “GHVJx” “GHVKx” and perhaps “GHVLx”.

But you will have to wait a few mounth to install /e/ onto a “GHWAx” stock ROM where “W” is 2023 and “A” is january


Well, I can’t take picture now, as I dont have it with but, found this : [](Google image link)
Wich is very close to mine. The one on the right is similar to the first 10 second screen (in which i can push power button to shorten it), and the one on the left is almost similar to the second screen where i stay stuck, except the warning sign and message are over Samsung logo, and of course, mine is a S10+

OK, thank you for those informations Piero.
I’ll try as soon as I’m back home (in more than 7 days actually…)
And do you know were I might find those compatibility information between /e/os and the stockroms? (I mean something more global for the different versions…)
Also, wouldn’t it be wise to tell in install instructions to check those compatibility MAJOR details?

I’m finally back home, and finally I could try what you suggeted Piero: Installing e 1.7 over the HVJx stockrom.
It worked successfully. I still have the warning screen but I’m not stuck here anymore. Great relief for me.
Thank you for your help.

I’d like to know if I may do the update of /e/ os or should I stay to the 1.7 version to be sure don’t loose my os?
Thank you.

1 Like

Keep the .ZIP as a working build if you want to reinstall it one day (no archive on /e/ website).
You will be abble to update when proposed or later if you prefer to see reactions of the first users.