Bootloader lock

Hello everyone,

another new happy eOS user here. Just yesterday I successfully installed eOS on my Fairphone. Did not lock the bootloader yet, out of fear of bricking my device. I understand that no guarantees can be given, I simply ask here to verify my understanding of the matter is correct.

Here is information about the original Android system installed on my device (after the latest updates were applied):

I installed eOS from following archive: “IMG-e-1.20-t-20240220382010-stable-FP5”.

So far my phone is not bricked and works fine (4G/LTE, calls, WiFi, camera, no problems discovered). I did not reboot it yet. Bootloader ist still unlocked. The latest security patch seems newer on eOS than on the original Android version.

My questions:

Am I right to assume that after locking the bootloader no bricking should occur?

Is it possible, that after locking the bootloader everything will be fine, but after a future update the device will brick?

Should I lock the bootloader, or leave it unlocked just in case?


Use the following command to check whether the bootloader can be safely locked again: Execute …

fastboot flashing get_unlock_ability

It it returns get_unlock_ability: 1 : bootloader can be relocked

It it returns get_unlock_ability: 0 : do not relock the bootloader


I tried, here’s what happens:

$ fastboot flashing get_unlock_ability
< waiting for any device >

fastboot devices also does not return anything. adb devices shows my phone.

I suppose the fastboot command needs to be executed from the bootloader, after “adb reboot bootloader” was executed?

1 Like

hello @Igorevich, welcome to this forum.

i am not a Fairphone specialist, but as i understand YOU MUSN’T RELOCK YET because it look like the android security patch dates don’t match the requirement.

:warning: Security fixes

This /e/OS v1.20 version includes the Android security patches available until January 2024.

i think you have to wait about a month (or two) for a future /e/OS release.
other solution could be installing previous FairphoneOS version (FP5.TT45.A.141), then /e/OS (e-1.20-t-20240220382010-stable-FP5) again.

a better skilled user will confirm and precise the advise…

1 Like

No problem, I can wait for the next update.

Just curios about how to correctly run the above command “fastboot flashing get_unlock_ability”. Should it be executed when inside the bootloader? Oder should it work just with enabled USB-debugging when the phone is connected to my PC?

  • adb commands works when the device is booted in “normal”/system mode or recovery mode
  • fastboot commands works when the device is booted in “fastboot”/bootloader mode

I tried just now, and here is the result:

$ fastboot flashing get_unlock_ability
(bootloader) get_unlock_ability: 1
OKAY [  0.000s]
Finished. Total time: 0.001s

It appears as if a relock is possible. But the security patch level in the settings (checking from inside e OS) is actually 2024.01.05, which is lower than the original security patch level of 2024.02.05.

I will be waiting for the next update and leave the bootloader unlocked for now. It’s only really affecting Netflix, so this should not be that big of a problem.

Relocking bootloader will wipe your data, not sure if you are aware of it

Did you install ‘stable’ or ‘dev’?

Thanks, I am aware of the data being wiped. I installed the ‘stable’ revision. The thing is, if the bootloader remains unlocked, Netflix app does not function (it claims connection errors). Netflix does not seem to work over a web browser on mobile devices and forces you to download and install the app.

If there was a way to easily watch Netflix with unlocked bootloader, I would not bother locking it. I’m not aware of any other problems with an unlocked bootloader as of now…

my bootloader is unlocked on a ‘dev’ T build and netflix works fine. I had issues on the same device when I had ‘stable’ R, also unlocked bootloader

Interesting, is it safe to assume that a future update will fix Netflix issues? Or do I have to change over to a ‘dev’ T build?

I think it was an issue with my device.

Maybe ask in a post if someone uses Netflix on their FP5’s on ‘stable’

1 Like

From reading other posts, I was under the impression that locking the bootloader helps the Netflix app to connect to the service. Now, looking deeper into it, it seems the actual reason is Netflix not supporting microG: /e/ OS and Netflix - #2 by ljahn

I tried messing around with microG settings, without success.

Oh well, on the bright side this will cut down on my screen time which is good for health.

That is old news in my opinion. Since I started with e/OS/ around 2022, I had a FP3, XZ2 Compact and now Pixel 4a and only, like written before there was an issue once with it.

I use still the GSI with Q on a tablet and it works.

I really think it might have to do with the FP5, maybe the diffrent security patches… I mean e/OS/ is at a certain month and actually it is newer on the device :person_shrugging::person_shrugging:

Software has strange ways sometimes…

There is a useful discussion of the broader subject here

1 Like

On the FP forum many users claim, that they are watching netflix. The issue is, only SD resolution works.

The basic connecting to the service seems to work on original Android version shipped with the device.

Searching for micoG + Netflix gave

From the second Moderator comment

So you won’t be able to use advanced privacy VPN at the same time, but do you use it at all?


The second link seems to contain a solution to misbehaving apps:

Will be trying that out and reporting back today. So far, Netflix and PayPal wont start for me

PayPal app? Will payPal work from Browser by httpts when you “Add to Home screen” (top right 3 dot menu) would be my preferred option anyway.

It works from a browser just fine. But the app only sends notifications. When I start it, it only tells that its downloading German language files and hangs there forever