Bootloop after update 0.15-p SAMSUNG Galaxy A5 2016 (SM-A510F)

I installed the update 0.15p this morning, but when the A5 reboots, it hangs in a bootloop Only the Samsung-Logo appears over and over again.

I tried to install it again over TWRP, but it didn’t changed anything. Now I’m back on 0.13p

Any ideas?

Thanks for your support

Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone

When this has happened to me (on other devices), I have been able to fix it by the following, all in TWRP:

  1. Backup your data
  2. Format the data partition (not just wipe)
  3. Flash the ROM
  4. Restart the phone
  5. Go through ‘Setup wizard’, setting any password, PIN or pattern to what it was when you backed up
  6. Reboot in recovery
  7. Restore data partition

The update isn’t available anymore. So maybe there was really a bug in this version.

Thanks for your help.

It now runs again on version 0.13p :grinning:

The pie update was removed from the servers. A Q build for the a5 should be available later today. First build will have to be manually flashed.

Will the Q build for a5xelte be available in the same place as the previous versions (here:

For the moment, nothing visible.

Yes it will show up in the same location. Builds need to be made public. Will check and update as to when this will be made live. I was expecting this to happen yesterday as the builds are ready.

1 Like

Hello together,

I just installed the new Update-Version 0.15
It seems to work fine, but when I start the phone. I get a message:
There is an internal problem with your device. Please talk to the producer.”

I translated it from German so in English the wording could be different
In German it says:
Es liegt ein internes Problem mit deinem Gerät vor. Bitte wende dich diesbezüglich an den Hersteller.”

I don’t know what kind of problem it could be. Because the message hasn’t appeared before e.g. in version 0.13.

Looking forward to your advices – thanks a lot.

Hi @BioBiker26
do you still have this error?
have you noticed any other problems? any improvements?

Thanks for your feedback.

Hi @saroumane38,

unfortionatly or luckily :wink: I haven’t found any other problemns. I just tried to send a bug report, but there was no confirmation notice that it really worked.
This notice from Android only appears, when I start or restart the phone. If its powered everything seems to work properly.

I switched the language on the device to English so here is the original wording of the notice.
There’s an internal problem with your device. Contact your manufacturer for details.”

You can click “okay” and then it’s gone until you restart the phone.

If I can do anything to help finding the bug, please let me know.

Thank you very much for your work and your support.

Hello @BioBiker26
I made the upgrade from 0.13-p to 0.15-q on te same device.
For that I used only TWRP, first to make a backup then to install the zip directly without any wipe.

The installation was very fast.
On reboot (and every reboot since) I get a message saying “an internal problem with your device has occurred. Please contact the manufacturer for more information.”
But other than that, everything seems to be working perfectly, without problems.

Thanks for the work done

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.