Bootloop fresh install [Pocophone F1]


I am trying to get /e/ running on my Pocophone F1.
Following the instructions on the wiki.
Including flashing to the older firmware (Android 8.1).

Somehow I am stuck on bootloop after “device encryption”.
Did try it a few times.

With all other custom roms I don’t have issues.



Hi Tim, welcome to the /e/ forum.
I have a Pocophone as well that I recently converted to /e/ and I had a similar thing. Just need to recall how I proceeded…

So, just to be sure: you have TWRP on the device?
You installed on older version of MIUI (based on Oreo) on your device and you faced bootloop after installing /e/, right?

Hi ralxx,

that’s correct.
I got back to the original stockfirm (8.1) flashed it.
Booted the stock, to enable USB debug.
Flashed TWRP, cleared cache/data etc.
Rebooted into TWRP
Flashed /e/ and then it got stuck after encrypting device.

So that means you have at least correct firmware.
When switching amongst different Android versions I often had that. One thing tht was of big help was ot re-format the partitions /data/ with a different file format and again the initial one:
Go to TWRP > Wipe > Advanced Wipe > select Data >Repair or Change File System > Change File System > chose exFAT
Once that is done, do another format but this time Ext4.

Then re-install /e/ (oreo).

Btw. did you already try to install Lineage 15.1 after going back to MIUI/oreo
You could try to get Lineage 15.1 (unofficial but working you could find here:

Let me know if that works…

Thanks :slightly_smiling_face:
I’ll give it a try.

Lineage 15.1 (official) is working fine tho.

so after a few hours trying.
With different MIUI (EU) firmware, which got met constantly boot into fastboot.
So back to the original ROM, it got me back in bootloop.
Also re-formatted as you said.

still no luck :frowning:

  • So, even with the original ROM (guess that’s Miui10/Android9?) Poco is not working and just entering Fastboot?
  • With all your attempts, did you always get the same behaviours with your Poco (straight to Fastboot)?
  • What’s your TWRP version? Make sure that you have the latest (3.3.0)

One thing that could be the issue in your case: You used MIUI-EU ROM, right?.You actually need the stock ROM afaik (no matter if developer ROM or Standard MIUI ROM, but stock).

What I’d do in your case:

  • Reinstall MIUI (Android 8.1 stock) using the MI-Flash Tool. This needs to be done from a PC. Make sure that you do not re-lock the device (settings are in the bottom right corner of your PC screen. For flashing you need to unzip the ROM. Explanations are here (the ROMs in the article are not the correct ones, they are Android 9, but the installation instructions are well straight forward).


  • Reinstall latest TWRP via Fastboot.
  • Wipe, Data, Dalvik, Cache, System
    (you should not have a vendor partition, right?)
  • Change file system on Data to exFAT and then again to EXT4 (as described above)
  • Install /e/ then.

did all… :expressionless:

You won’t believe it.
By removing the extended SD card, I got it working :astonished:

thnx for your help! :slight_smile:

1 Like

I’ve the same problem… and now I follow your advice and remove the sd card but… not yet : No os isntalled after the sideload … do you have anything before I don’t ? I follow exactly the procedure provided by eOS

Hi @Cyrena, please describe what is not working.
You have a Pocophone? What was your last OS installed? What did you do then?

I follow the instructions to switch to eOS but always when I 've flash the new ROM TWRP tell that there is no OS installed. Indeed if I reboot it, my pocophone shows the screen FASTBOOT… I do it 5-7 times and the last one I try with Lineage and it works :wink:

Hi @Cyrena, if you had running a Pie based Rom runnimg before you need to flash miui 9.x (based on Oreo) first, and make sure that you flash the original (stock) miui global or chinese version, EU version won’t work.
Otherwise I cannot help if you do not describe more precisely what you were doing and at what point the installation process did not work.

Hi @Cyrena the Lineage OS version is it Pie? The /e/OS ROM is on Oreo. That could be the reason why the /e/OS ROM does not work. Downgrade to a lower OS i.e. Pie > Oreo does not work for most devices . You would have to wait for the Pie Os for /e/ to come out. We should be starting the testing next week.

Hello bro hope you will reply me
Please read this fully
I’m sending this message on a frustrated state
My Poco F1 have a problem
The problem started when I tried to install a custom ROM mistaking berrilliyum with violet version
And Im stuck on fastboot
Then as you know the only way is flash the official miui rom
I did it via mi flash tool from a pc
I thought my device is gonna bootup
And that’s where I started to feel the real issueMy device won’t boot
Still stuck on fastboot
Even if I try to get back to recovery
No use it won’t work it still back to fastboot logo
And I tried to install twrp via pc when I give command “fastboot flash recovery” it flashed and then I I gave the command “fastboot boot recovery”
It said failed to authenticate device
So I have no idea what to do
Even I have a unlocked bootloader
I don’t know what to do
When I searched in GoogleOne person found the solution and said to install the miui 10 android version 8.1 version rom
And I did surprisingly it booted up
Then I tried to install twrp via pc it worked
Then I tried to install custom ROM it installed successfully the disable force encryption file successfully flashed
But back to square one I’m stuck on fastboot
I again installed miui 10 based on Android 8.1
Then I again installed twrp and I tried to install the disable force encryption file separately
But as soon as I boot in to system it starts encrypting againThe issue here is not only that I won’t do OTA update too
If I install OTA update
It still goes on fastboot
I’m sick and tired of that bunny logo
Please bro if you find any fix please let me know
I’m stuck on Android 8.1 with miui 10