Bootloop issue (SM-G950F)

Good morning all,

I tried to install /e/OS with the Easy-installer, but I’m stuck in a bootloop.

Actually I followed the instructions of the program (delete all acounts, unlock OEM and developper options, etc.) but just after the first download, when you should quickly change of macro to run teamWin, I perform accessing the recovery mode, but I didn’t know what shall I have to do (the installer said that I must see the TeamWin screen). So I tried to reboot but it ran on the normal software. So I tried to restart the installation process of easy-installer, but I stayed stuck at the same step.

Now I don’t know why but my phone make a bootloop every time I try to power it on. I can stop it by entering in the downloading mode and exiting as I made during installation (pressing power+bixby+volume down),

According to this picture, It seems be a firmware issue.

I tried to:

  • reboot from recovery mode
  • wipe cache data
  • restore factory state
  • download firmware from internet (SamMobile) as it was written on my screen

but nothing worked.

I attach a photo of my phone in recovery mode with the error and the country code.

I hope someone will help me to find a solution, because I would try /e/OS.

Your image shows the original Samsung Android recovery. One of the most significant steps in the middle of the Easy Installer process is described in this link Your first boot into TWRP.

This is the same as Easy Installer Samsung users fail to boot into TWRP (#2678) · Issues · e / Backlog · GitLab.

In this case the reason for the bootloop is that Easy Installer has probably compromised the /system partition and the device cannot boot. Samsung Android Recovery is “in charge”; this leads to messages not very helpfully guiding you to “go back”! :slight_smile:

Easy Installer will nearly always just pick up again, the existing downloads will be reused but will be checked and verified as you start Easy Installer from the beginning.

just for other to hit your thread with search:

#fail to open recovery_cause(No such file or directory)#

#Reboot Recovery cause is [UNKNOWN]#

File-Based OTA
Supported API: 3
E:unknown volume for path [/odm]
E:unknown volume for path [/vendor]

dm-verity verification failed
E:[libfs_mgr]is_dt_compatible(): firmware info was not valid: '/proc/device-tree/firmware/android/compatible': No such file or directory

in the stock recovery (your photo) newly flashed partitions are unknown and trigger dm-verity to fail. You need to get into twrp. twrp would boot a kernel without dm-verity enabled, and the process could continue.

The easyinstaller will instruct the device to reboot with twrp, if you rebooted on your own there are no such instructions and the stock recovery will boot and subsequently fail.


There is a “special” step during the process for Samsung phones. After the recovery is installed, you’ll have to leave the download mode (by pressing continuously on “Power”+”volume down”). As soon as the screen become black (like an off device) you must immediatly start into recovery … (read more at the FAQ)

The fact is that I can’t continue the installation with easy installer without normaly starting the device because it isn’t detected.

Is there an alternative ?

Please can you try connecting the device to PC, start Easy Installer, then try to power the device from Recovery mode to Download mode with button presses, if no reaction from Easy Installer, try the reverse and Force stop out of Download mode into Recovery mode. There is a chance that this will trick Easy Installer into starting.

If it fails please tell us are you using Windows or Linux on your PC?

I tried but it doesn’t work.

I am using windows 10.

Thanks for your reactivity

1 Like

From Info about Samsung Galaxy S8 - dreamlte (SM-G950F) we find the instructions to “Install via command line (for advanced users)” → Install /e/ on a Samsung Galaxy S8 - “dreamlte”

Maybe it looks a bit intimidating to start, but please try to break it down in you mind into easy stages! :slight_smile:

This is done in this tutorial [HOWTO] Install /e/ on a Samsung smartphone with Windows easily

Please allow yourself time to let your mind get used to it!

If it feels like you lost the phone – you definitely did not, it is quite hard to brick a Samsung.

Your device is only missing the Normal booting part – system.

The two modes you need are working fine, Download mode and Recovery mode.

Please be aware that you need the phone charged >70% to proceed. It can be reassuring to halt the phone (from Recovery mode) and see it charging correctly.

Don’t hesitate to ask again if you get to a block with the instructions – much better to make sure you can follow step to step before committing further, I think.

Good luck

You can also try to install twrp thanks to Odin software then instal e/os .ZIP package.
After cleaning all cache ans dalvik…etc… Everything should works.