BQ - Aquaris X - bardock - Documentation Suggestions

…Enter suggestions to improve documentation in this category. Do not raise bugs or issues here…

Hi, I’m not sure, if I’m right here but it looks official :smiley:

I used my BQ Aquaris X for about a year now and I’m amazingly happy with this device. Unfortunately, I found ou that LineageOS has removed the device from the “Official Supported” list. Will this happen the same way with eOS? Is there still a maintainer for this device, also regarding to a possible upgrade to eOS “S”? Will this happen genreally? Apart from programming, is there may a way to help?

Kind regards

For your information: There is an update available for Android T(13) or /e/os 1.15.

I have a question about this:
In the download section for the Aquaris X, the latest update is 1.15 with Android T(13), but the latest recovery is for 1.14 with Android R(11). Can I use the 1.14 recovery for the 1.15 Android R(11) update or even for the 1.15 Android T(13) update?

My last time flashing a custom firmware or rooting my phone was at least 6 years ago.
So I am not used to this and depend on the guide and followed the guide step by step.
I wanted to install 1.14-r first to be on the safe side

Edit: My first problem was solved by multiple instalations and deinstalations of the driver.
Somehow the same driver didn’t work the first seven tries.

Edit 2:
When I flash the new recovery I suspect that nothing happens. The recovery looks the same.
That was the answear i got:

C:\>fastboot flash recovery recovery-e-1.14-r-20230817321316-dev-bardock.img
Sending 'recovery' (28582 KB)                      OKAY [  0.752s]
Writing 'recovery'                                 OKAY [  0.396s]
Finished. Total time: 1.262s

I tried to flash a twrp recovery and it still looked the same.
I think I should stop and ask for help before I brick my phone.
In the forum i found recoverys that looked more like this: Picture
Can anyone show me how the new recovery should look?

Edit 3: Jeah I was right. I simply installed the e/os/ recovery 3 times without rebooting and that helped. Don’t ask me why.

Ok, I solved all my problems.
I have now 1.15 Android R(11) running.

The first two things (bugs?) I noticed that once after a restart the UI crashes when you enter the settings.
But only once.

The second thing ist that the in the security settings the fingerprint option is missing.


nice to have an answer here in this thread :smiley:

So, I can’t help you with your problem, but it seems to be solved (nearly). Since I saw that the support was cancled, I switched the phone but since maybe 1 or 2 months I use the LineageOS ROM on my BQ Aquaris X again.

To the recovery-thing: As I read in some (old) forum posts it’s not quiet a good idea to use an other recovery(-version) as intended. Your way should be a good one. If they drop an matching recovery, i will may switch back to e/OS again.