Brave Browser not opening; "Bliss Launcher has stopped" error message

Hi. Brave browser is suddenly not working. When I open a shortcut previously created with Brave, I receive the error message “Bliss Launcher has stopped” and the web shortcut will not open.

I uninstalled the app and reinstalled it. However, I can’t find a shortcut on my phone to directly access Brave. When I go to the app store, it says it’s installed. Clicking on the “open” button in the app store does not launch the app.

Any suggestions? I’ve forced a close of the app and restarted the phone a few times. Those did not help.

Thank you.

Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone


Not much help, but I have exactly the same. Brave wanted to update and now it’s showing in Apps, but with no obvious way of opening it.

I opened also another thread, bc of this. Same issues. It is showing in apps, but can not click to start or to delete the app.

I just used Brave without any problems. q-0.1620210424112062 on XA2 pioneer under Shelter, Brave version 1.23.74

I hope they get it worked out. I like using Brave.

I kind of think the update (1.24.86) broke it. Managed to uninstall the “invisible version” via Aurora Store, since the /e/ App store can not. There is just the “open” button that does not work. Maybe I’ll get an older version - like yours and try it again. (if it does not work out to get an older APK, I’ll stick to the Brave Beta Browser, because it is working).

I have the same! I can’t find Brave browser on my fairphone. If I remove it and download it again it is still not shown. I also force stopped it, still no change. In Apps it says it is downloaded, but the “open” button doesn’t work. Does somebody know how to fix it please?



  • Settings > Apps > Brave > Storage > Wipe cache
  • then go back and uninstall,
  • reboot,
  • install latest apk from Aurora or brave’s site…

If it doesn’t solve, perhaps uninstall then
File > Android > Datas
delete Brave’s folder.

Good luck.


Worked for me, thanks a lot! Have not found the folder before, going to close my other thread!

Thanks. I don’t see a Brave subfolder in the Datas folder. So I’ll try your other recommendation.

I’m not familiar with Aurora. I welcome any feedback or suggestions you have on using them to download apps.



So you may wipe app’s cache then wipe app’s data too, from Seetings > Apps > Brave, before remove it.

Aurora : download its apk from F-Droid, install, connect as Anonymous and download and install Brave. It’s easy.

Thank you! Somehow Aurora also has a meltdown (“failed to connect to …”), so I’ll wait untill that is fixed to try that option.
Installing it from Brave’s site is through Google Play store and then you need a login, but I don’t use Google (with a login).
Then I tried to uninstall en delete Brave’s folder but I can’t find it after wiping app’s cache and data…
Can’t reinstall it from Apps, then I get the same problem as before.
So I guess I will wait untill Aurora is running again.
Thanks again!


You could try to install from an apk store:

The same problem arises when I installed it from APKPure, however with APKPure you can view the version history and install an older version and it works. The version mentioned above (1.23.74) is what I tried and it works fine. If it automatically updates then might face the same problem again.

I don’t know what the deal is with Brave really but I have it on a few ROMs. I used FFUpdater (available on F-Droid) to install and keep it updated. However, the latest version of FFUpdater had to remove Brave from the app because Brave no longer provides standard apks on GitHub. You’re now expected to install Brave from the Play Store if I’m not mistaken.

See the FFUpdater README Deprecated Browsers section as well as this GitHub issue (linked in that README).

My current Brave is 1.24.82. I’ve seen one or two later releases on GitHub but have yet to check if they work.

1 Like

Okay, so this was interesting. The version of Brave available on the Play Store, APKPure, and /e/'s Apps store is 1.24.86. It is that version that changed to aab (Android App Bundle) instead of apk.

Moto G5s Plus sanders, FireHound Oreo ROM, microG, patched Play Store.
APKPure version installed just fine but Brave was nowhere to be found in the launcher (Lucid) though it was present in Settings -> Apps & notifications. Uninstalled.

Essential PH-1, /e/OS Pie. Installed fine from Apps but Brave was nowhere to be found in launcher (Lawnchair 9.1a3). Went back to Apps and tried to launch Brave using the OPEN button. Nothing happened, did not launch. Uninstalled.
Went to Aurora Store. Searched for but could not find Brave. Odd.

Back to FireHound, install Brave from Play Store. All good there.

The Aurora Store was weird, so…
ZTE Axon 7, Candy7 Nougat ROM, no Google or microG. Brave doesn’t show up in Aurora Store. Super strange.

That all said, it seems the Brave people backtracked on the aab thing. Tested four apks from two 1.25.x releases from GitHub. Installed and ran fine.
I publicly confirmed that so hopefully the FFUpdater dev will add Brave back to the app. It’s the best way to keep the browser updated (I use it for Iceraven also).

1 Like

In /e/ Apps you can disable automatic updates. This might be annoying as it will be for all apps, but hopefully the issue with Brave will be temporary. This is a shame as I have been enjoying Brave and now use it on all my devices.

Will all apps that use AABs cause a similar problem? This will soon be standard practice with Android apps, won’t it?

Didn’t know about that! As soon as Aurora connected again I used that, but thanks for this info I might use it in the future.

Curious why you choose to utilize FFUpdater to keep Brave/IceRaven updated? Any other reason than it checks the SHA256 checksum?

*And avoid non-Fdroid installation mediums?

Only way actually. Otherwise I’d have to check their githubs which isn’t ideal.
Neither of the browsers are available via F-Droid, and Brave is currently still at the version (from Play Store and Apps) causing issues though a couple/few newer releases are available.

With FFUpdater you set your check interval (hours, days, weeks) and when a new version is available, it’ll notify, then you can immediately install it from the app.

1 Like