Bricked Samsung S6 Tab Lite wifi

I recently decided to switch to e/OS/, and to give it a try I decided to flash it on my Samsung TAB S6 Lite WiFi (codename: sm-p610).
I followd this guide: and successfully unlocked bootloader. After that, I powered off the device, went in download mode and run “heimdall flash --RECOVERY recovery-e-1.14-s-20230819321663-dev-gta4xlwifi.img --no-reboot”. After this, everything has been fucked up. The tablet went in bootloop, and it wont turn off or anything. after a full night of bootlooping, the battery got drained and I was able to re-enter in download, I tried to reflash other recovery but nothing works, the tablet is bricked. Now, what can I do? the battery Is almost dead so I should be able to enter download mode, but nothing seems to work!

a Samsung device is unbrickable !

Which Samsung stock firmware is installed? Android 10, 11, 12 or Android 13, One UI 5.

1 Like

@piero but its bootlooped / I cant work with it anymore :frowning:
@anon29344687 latests, if i remember correctly android 12

On my device, there is no home button anymore. Anyway, i pushed up + power buttons but nothing happens, only one time i had an error like wrong signatures etc and it went in download mode

Also, latest one ui. I updated everything before going into custom rom process

in place to hold the tree buttons, you have to hold the two available and when doing that, insert the USB cable in the device.

Boot Modes


With the device powered off - hold Volume Up + Power.


With the device powered off - hold Volume Down + Volume Up and connect the USB cable to PC.

I know this, but it doesnt work.

Please see also here:

As Piero said:
Power off the device, and boot it into download mode:

  • With the device powered off, hold Volume Down + Volume Up and connect USB cable to PC

Please read carefully these steps:

It took me several times to get the right timing with these steps…but it should work

Amusingly you have the SM-P610 ie S6 lite 2019 edition and not the S6 lite 2022 (not officially supported)

Okay, I think I have the 2022 version, I bought the tab like last year… now what? How can I make it work?

or at least, how can I flash original recovery to make this tab usable again

What model is this?

SM-P610 that the correct model and should work

it does not, I cant send video but its bootlooped. I can enter download mode but recovery doesnt work

What OS do you use? Did you already did
heimdall print-pit
heimdall flash --RECOVERY recovery.img --no-reboot

heimdall flash --RECOVERY recovery.img --no-rebootHeimdall v1.4.2

Copyright (c) 2010-2017 Benjamin Dobell, Glass Echidna

This software is provided free of charge. Copying and redistribution is

If you appreciate this software and you would like to support future
development please consider donating:

Initialising connection…
Detecting device…
Claiming interface…
Setting up interface…

Initialising protocol…
Protocol initialisation successful.

Beginning session…

Some devices may take up to 2 minutes to respond.
Please be patient!

Session begun.

Downloading device’s PIT file…
PIT file download successful.

Uploading RECOVERY
RECOVERY upload successful

Ending session…
Releasing device interface…

print-pit worked, I unlocked the bootloader and I was able to enter in download mode, and flashed recovery (the progress bar was also shown during process). But I cant use the new recovery, it entered in bootloop just after I leave the power + down to restart the tab.

did you download the lasted recovery from here?

Command should be eg.
heimdall flash --RECOVERY recovery-e-1.14-s-20230819321663-dev-gta4xlwifi.img --no-reboot

What Android version did you have had?

Android 13, latest ui. I ran this exact command (taken from zsh history)
heimdall flash --RECOVERY recovery-e-1.14-s-20230819321663-dev-gta4xlwifi.img --no-reboot, so yes its the same

maybe I should try older ones? I have no clue how to fix this