Bricked Sony Xperia Z5 With Flashtool

My Z5 is a 3G phone so it no longer can be activated with a wireless network. I was attempting to restore it back to the factory Android ROM so I could use it as a wifi phone in conjunction with Google Voice. I found the appropriate Sony Android image file bundle and inadvertently locked the bootloader while the phone was connected to my PC which was running Sony Flashtool. Now the phone only vibrates when I hold the power on with the volume rocker up. It won’t power on. I’m assuming that when I locked the bootloader it interfered with the /e/ ROM. If anyone has any suggestions I’m all ears.

By the way my 4G One Plus 6T is still working fine with /e/.

Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone

Will it start in fastboot or flash mode (either volume up or down while you insert USB cable). If so, you may be able to unlock the bootloader with Flashtool. Good luck!

When I attempt to connect to Flashtool with the volume up or down it gives me:

ERROR - Drivers need to be installed for connected device.
ERROR - You can find them in the drivers folder of Flashtool.

I downloaded and installed the latest version of Flashtool for Windows. During one of my attempts to use Flashtool it gave me the option to lock or unlock the bootloader before flashing the phone. I selected lock because I had previously tried using Sony Xperia Companion to restore the phone to the original ROM and Companion wouldn’t let me because the bootloader was unlocked. My reasoning was that if the bootloader was locked, Companion might have been able to restore the phone to the factory Android ROM and I would not have to work around Flashtool’s bugs. I didn’t realize at the time that Xperia Companion will not work with any custom ROM and that locking the bootloader would corrupt /e/ and brick my phone.

Before bricking the phone I had already tried unsuccessfully to flash the correct model specific Sony firmware to the phone using Flashtool. Flashtool would not recognize the ftf file that it had created from the Sony firmware. I did some research and found that there have been many people who have experienced the same ftf file problem. There are tutorials on YouTube regarding how to fix the problem. I’m now warning people that Flashtool has a major bug with ftf files it creates and that if they do attempt to use it that they should not select ‘lock bootloader’ when it prompts them to do so. I’ll never use Flashtool again with any phone.

Icm sorry FlashTool hasn’t worked for you (yet). I use it on Linux and MacOs, so I don’t have the driver issue you mention. It sounds like FlashTool is what you need to “unbrick” your device, so it may be worth spending sone time to solve the driver problem

Thanks for trying to help. If the phone won’t power on there’s no way to unlock the bootloader and to install any drivers from Flashtool. Flashtool no longer recognizes the ftf files it creates without copying and pasting numerous files from the ExperiFirm file list. I’ve also learned that when installing Flashtool in Ubuntu it has other issues that need to be fixed with numerous Terminal commands. It’s unfortunate that Flashtool no longer supports its app. That’s one of the hazards of using an old open source app, unless it continues to be supported it becomes dangerous to use. I’ve also read other threads where people who had problems with Flashtool were advised to try an earlier version. My Z5 is several years old so perhaps I should have used a version released not long after my Z5 was released. In any event I no longer trust Flashtool and will never again attempt to use it to install /e/ on any phone.

Here’s a thread I found regarding the Flashtool Error message:

The recommended fix didn’t help the person who posted the thread. The thread is 5 years old so you would think Flashtool would have fixed this issue in their latest version.

Here’s a thread I found regarding installation of Flashtool device drivers:


When installing the drivers here’s what happens:

Flash Tool Experia Driver Pack v1.9 (20160308) Setup.


Please wait while FlashTool Experia Driver Pack v1.9 (20160308) is being installed.

Execute: “C:\Users\ANYUSE~1\AppData\Local\Temp\Flashtool\dpinst64.exe”

At the same time another window pops up that says ‘Welcome to the Device Driver Installation Wizard!’ And the above file never finishes loading. I click next and it says 'Some drivers were successfully installed on this computer. Some could not be installed. The the Status column for more details.

If a device came with your software, you can now connect it to the computer.

Driver Name Status
{check)Sony (WinUSB)sa0113 Ready to use
(X) Sony Net (03/19/2015 … Install failed

I pressed the power button and volume up at the same time and plugged the phone into my PC before launching Flashtool. Here’s what happened:

Starting phone detection
Device connected in flash mode
Device disonnected
Device connected in flash mode
Device disconnected
Device connected in flash mode

The status changes every 10 seconds.

If the device driver wizard fails, do you have a standard Device manager open while this switching is going on?

Maybe the “failing part” of the device will show up as a :warning: “Problem device” while you work. Windows update now might manage to find the “correct” driver.

Thanks for the suggestion, aibd. I’ll try it when I have some time to spend trying to troubleshoot it further. I’m a PCLinuxOS and Ubuntu user so using Windows 10 poses additional challenges for me. I recently purchased a used PC with Windows 10 installed just so I could install Sony Xperia Companion. If Flashtool didn’t have so many bugs I would try installing and running it with Ubuntu.

For others who are experiencing similar issues and don’t usually run Windows I’ve posted a link below with instructions regarding how to use Device Manager and other methods to diagnose the problem.

You can do this on ubuntu with xperifirm and newflasher. Getting the sortware set up first can take a little while. I’ve not done it for a while now but to experiment I’ve just got xperifirm working from scratch on pop os following the instructions linked below.

My old device is an XA2 and the button press combos when connecting to pc were:
Hold vol up whilst plug into pc for fastboot mode
Hold vol down whilst plug into pc for flash mode (this is required for newflasher)

Other combo’s (useful in bootloops etc), with device unplugged:
Hold power & vol up until one vibration then release > to restart device
Hold power & vol up until one vib, keep holding, three short vibs, release > to power off device

I haven’t got time to write more just now but there are some finicky steps to complete before/during flashing.

Latest Xperifirm
Xperifirm install/setup on linux