BUG // Problem notification - Diffusion of the screen


I need to use and access my FairPhone 3+ phone under eelo e foundation android version 10 with anydesk remotely with unattended access (no need to validate the connection from the phone).
Anydesk works, I access it but the problem is that when I connect, I systematically have the following message (see image):

I would like to no longer have this message and no longer have to press “Start”, because it is for professional use and it blocks me in my job.

PS: I tested with teamviewer too, the same, so the problem comes from the phone’s operating system and not from the applications.

Waiting for your solution,


Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone

This is not a bug. AnyDesk says …

" Warning: As of Android 10 and depending on the smartphone provider, 8 and 9, users will get an Android security prompt regarding casting when connecting to the Android device. For most, this message is unskippable and requires the end user to manually accept the prompt before the connecting user is able to establish the session."

Works as designed.
I found hints on how to get rid of this security prompt here and here.


I don’t want to install any weird Chinese app.
Is it possible to upgrade the fairphone to the latest version of android? If yes, how?
If I switch to the latest version, will I still have this message problem?

In one of the links somebody suggested an ADB command without having to install an App, though. To try you would need the package name of the AnyDesk App, enabled ADB on the phone and a USB connection to a computer with ADB on it.
If you need help with this, we could walk you through.

This was obviously introduced as a new security measure in recent Android. It’s not likely it will go away in more recent Android.

I can’t find the link in question that talks about proceeding without having to install Chinese applications (shizuku, etc.).

Yes, if you can guide me that would be nice.

Otherwise, as I would prefer to have the latest version of Android, if there is a way to have the latest version and also have this problem with anydesk in addition, that would be even better.

Please define “remotely”.
If device is connect with USB to the computer, or connected to the same WLAN, you could try GitHub - Genymobile/scrcpy at v1.22.
But this will not work for distant remote devices.

I’m talking about this at the current end of discussion at the Teamviewer community thread:

"You can also just run this ADB command:
adb shell appops set com.teamviewer.host.market PROJECT_MEDIA allow"

com.teamviewer.host.market is the install package name of the Teamviewer App.
The package name of the AnyDesk App should be com.anydesk.anydeskandroid (visible in AnyDesk’s link addresses to the Play Store and Galaxy Store).
You can confirm the correct package name on your phone in Settings - Apps & notifications - (select the App) - Advanced - (the package name is given at the bottom of the page).

To enable ADB on your phone and on a computer:

  • If not done already, make the Developer options visible on your phone by tapping on the Build number in Settings - About phone a few times until you are being declared a developer.

  • If not done already, enable Settings - System - Advanced - Developer options - Android debugging

  • Connect your phone to a computer via USB.

  • If not done already, download the current Android SDK platform tools to the computer and unzip the ZIP file to a folder you can navigate to easily.

  • Open a command line/ terminal and navigate to the folder to which you unzipped the tools. If you are unfamiliar with the command line/ terminal, here’s a really good and short 1 page introduction to everything you need for now … https://tutorial.djangogirls.org/en/intro_to_command_line/

  • Enter the adb devices command to display an ID of the phone to make sure that ADB works with the connected phone (upon first usage the phone should ask you to confirm this access from the computer, there you should also be able to select that the phone remembers that decision, if you want).

If you got that far successfully, you can enter the following command and see whether that helps with your issue …

adb shell appops set com.anydesk.anydeskandroid PROJECT_MEDIA allow

I placed the adb command, I no longer have the message, but it still does not work.

Is it possible to upgrade to android 12 with eelo?

If yes, how? Because I tried yesterday, I did not succeed.

In fact it only works if the anydesk window is active. And yet “Always allow connection requests” is checked. So we can say that it doesn’t really work.

Android 11 (R) is in beta stage currently on the dev release channel.

Which guide did you follow?

@Manoj: Can the FP3 upgrade guide get fixed? It includes the installation of TWRP and using ADB sideload, which is wrong, upgrading doesn’t work this way with the files provided for FP3.

All the upgrade guides need to be fixed. This is a task pending with our developer. If a FP user can share a correct upgrade guide, I can have that added in place of the current template generated ones.

1 Like