Bug while installing /e/ on Samsung Galaxy S7

Hi everyone,

I am trying to install /e/ (Oreo) on my Samsung Galaxy S7 (model: SM-G930F) by following these instructions: https://community.e.foundation/t/howto-install-e-on-a-samsung-smartphone-with-windows-easily/3186

I am at the 8)A)4 part. When I validated, I had some red error message because TWRP can’t decrypt /data partition. I followed the instructions to solve this problem but since I have selected exFAT and swiped, my phone is blocked on “Formatting” (see image below). It has been like that for 2 hours. What can I do?

Thank you for your help!

Heb

you MUST format data before flashing anything. That’s your issue. after formatting data with TWRP all should work fine

Thanks for your answer.
Yes it is necessary to format data but it has been formatting for several hours. This process shouldn’t take so much time, should it?

No, normally the format data will be finished after same minutes.

Have you tried this
4. Validate by dragging the “Swipe to Wipe” arrow from left to right.If red error messages show up, your phone is probably encypted but TWRP can’t decrypt the /data partition (it’s a common issue on Samsung phones).To solve that problem, go to Wipe > Advanced wipe, select “data”, click on “Repair or Change File System”, then on “Change filesystem”. Select exFAT (or another one if it doesn’t work, it doesn’t matter), then swipe from the left to the right. Redo the manipulation but this time select ext4 (which is the original file system) then slide from the left to the right.
Go to the 8)A)1. part of the howto.
5. Return to the main menu using the virtual buttons at the bottom of the screen.

Yes I clicked on “Repair or Change File System”, then on “Change filesystem”. I select exFAT, then I swiped from the left to the right. And now my phone is blocked on the screen showed on the photo above.

You can check for logs here /AppData/Local/easy-installer/" and share if available . Will pass it on to the dev team.

You may have to use an older version of TWRP than the 3.4.0 witch is build for android 10
Try the twrp-3.3.1.0

I am currently not using the easy-installer because I tried yesterday and it didn’t work. However, I do have logs. How can I send it? I can’t send .txt files and there are too many characters for a message.

Thanks I am going to try that :slight_smile:

So I tried an other version of TWRP but now, when I press the home, power and volume up buttons simultaneously, I am not in TWRP anymore: I just have a screen with “teamwin - Recovery Project 3.2.3-0”

Better : twrp 3.3.1-0

Same Thing. I tried 3.2.3-0 after 3.3.1-0 because it didn’t work

Ok this problem is solved, I used Nand Erase on Odin and I find TWRP screen again (3.3.1-0). I will try again.

Unfortunately, that’s not better with TWRP 3.3.1-0. The phone is still stucked in a fomatting process, with many “E:recv error on uevent” successively. What can I do ?


Sorry for all my questions, I am a novice :slight_smile:

You must have to
change the format system of the data partition to another,
Then, Back bouton, Back bouton, Back bouton, back bouton, Back bouton
Reboot to recovery
Rechange format système of the data partition to Ext4,
Then, Back bouton, Back bouton, Back bouton, back bouton, Back bouton
Reboot to recovery
Then install the /e/.zip

Edith : if you have already did all those steps, flash back the Samsung stock-firmware with Odin
and retry the twrp 3.3.3.1-0 and /e/ install

In fact I can’t go back (no button). Should I force the recovery mode by pressing the buttons home+power+volume up ?

edit : the last thing I did is clicking on "Change filesystem” and choosing exFAT

1 Like

So I selected ext4 and, after some error messages, I reboot. But now I am not able to install the /e/.zip. I tried to copy-paste it in the folders on my phone (next to My PC) but the phone is empty of any folder (there isn’t TWRP here) and it prevents me to past the /e/.zip (“the device doesn’t answer anymore or has been disconnected”)

So you can use the adb sideload command instead of the TWRP install feature
(https://doc.e.foundation/devices/herolte/install)
But with all those error messages you’d better flash back to stock Samsung firmware and restart a clean install process

After all you have to reboot into twrp. Than your internal storage should be shown in pc file manager

Finally, I succeeded to install it :slight_smile: The adb sideload command didnt work well (after reboot, the phone was stucked on the /e/ logo). I rechange format system of the data partition to Ext3 then to Ext4 and it seems to have been useful. After reboot, I could copy-paste the /e/.zip file in the internal storage and it worked well.
Thank you very much for your help !

1 Like