Bug with OpenCamera and HDR

If I activate HDR in OpenCamera and taking a picture, it takes the 3 pictures but then OpenCamera chrashs and the picture is not saved. Do your developer know about this problem? It would be great to have this HDR-feature - the pictures are much better.
(I’m using your S7.)

1 Like

I have just tried on my MI 5s Plus and camera is also crashing. Seems to be eOS related. Can you create a issue on gitlab ?

By the way, I have also try it on my Mi5s with MagmaOS. The HDR work but the result is bad. The standart mode with camera2api activated makes a lit better pictures.

Do you have activated Camera2Api ?



I’m not sure, because on all other phones I know, also with LOS, it works.

Thanks for your option on gitlab.

yes, it works on other rom’s, but as you can see on my pictures, the result is not good. Without HDR it’s much better

I tried in my S9+ and it doesn’t crash and the quality is ok.

Also having this issue on my unofficial build (Redmi Note 7). FWIW. Regular pictures work fine, but HDR crashes.

Same happens on my /e/ pre-installed S7 and I do have Camera2 API activated.

Open Camera crashes when photo mode is set to any mode but STD, fast burst, exposure bracketing or focus bracketing.

I have been looking for the issue on GitLab but I could not find it. Plus, I cannot make an issue since I do not find the option in here: https://gitlab.e.foundation/e/apps/camera. Could someone help with this?

Welcome in the community :slight_smile:

This issue has been reported here (and here).

So I was looking in the wrong place… :roll_eyes: Thank you, @Anonyme!