Build fails with "Can't detect android version"

Hello all,

This is my first time trying to build /e/ or any OS from scratch to be honest, but I’m running into a recurring error and I think it’s likely just something in the commands I’m running as no one else appears to have the same problem.

When I’m trying to build the /e/ image, it fails with the following error lines:
Syncing branch respoitory
sed: can’t read build/core/ No such file or directory
Can’t detect the android version

The error occurs when using both the Docker method ( and when using the non-docker method ([HOWTO] Build /e/ without docker).
I’m trying to build v1-nougat for herolte, i9300 or both and it fails with the same error each time.
I haven’t found anyone else in the forums with this same error but from similar errors I have expanded the resources of my Ubunutu VM to 500GB HDD and 16GB RAM.

I’m guessing it’s my build environment but any hints on troubleshooting would be much appreciated.

Thanks in advance,


Device and branhc specified as follows:

Hi @sludge3000 there will be an updated docker image with which you can build. The issue is TheMuppets Github site is down due to which the resources will not flow into the build environment.
We will be publishing a updated Docker image soon to resolve / bypass this issue.

Hello @Manoj , thanks for the speedy response.

Well at least it’s not me :slight_smile:

Is there an alternate location I can just swap out in the commands when running or should I just wait until the new Docker image is available? Any idea how long this may be?


You can check the documentation here. There aare some commands you can pass to point at a different location. I have never tested it myself so cannot be sure if it works or not. Ideally it should.